G code misaligned after exporting to controller

Hi all,
Ive just recently been having an issue with my x50 woodworker. I use vcarve pro to make files and when i import the ngc file to the controller the file is no longer aligned with the piece that i created in vcarve. Any help anyone can give me would be greatly appreciated.

Can you provide a little more detail? What do you mean when you say its no longer aligned? Maybe a picture, too, if you have one.

Hi David, sure. here is a quick file i made to show what its doing.

As you can see when i send it to the controller it appears everything shifts and is no longer aligned with my project piece.

Have you tried running this on scrap wood to see how it actually cuts? Is it shifted (like you did an offset in the origin in vcarve), resized, or some combination or something else?

Do you have another file, preferably an older file that worked, that you can load up and see if it looks strange?

If you create a new, simple project, does that project seem correct?

I’m trying to identify if the issue seems to come from the 1F controller (the old file looks wrong, too), the current file (this file is off, but not the new, simple file), or possibly something with your CAM software (bothe this and the new file seem wrong).

1 Like

In the second screenshot I can see that the Y zero line is below your material border. Make sure “Use Offset” is unchecked in the Job Setup menu.

1 Like

Thanks, Grim. Thats what I was referencing as origin offset, but wasn’t at a PC to get the shot or wording exact. I’ve never liked the term “XY Datum Position.” and think I’ve permanently blocked it from my brain. Origin might be the wrong term, but it makes sense in my head!

Thank you both for all your help, i have no idea how that box got checked but that was it! Thanks again!

1 Like

Excelent! Im glad we could help.