Help with Jtech Laser first use

Hello,
Are there any videos/instructions for the very first time firing up the laser?
I watched and have installed the laser.
Some questions:
In the Setting Up the Controller, do you have to manually set this back and forth every time switching from cnc to laser?
I have Vcarvepro and plan on purchasing the laser add-on. Onefinity is not listed. What laser post processor should I install from Vectric?
Again, I need instruction on what to do next. I have no idea.
How do you “zero” the laser?
Have past issues involving the laser firing been resolved?

If using the Makita router, you don’t need to change the settings in the controller after you setup your laser.

I use Lightburn so I cannot help with VCarve. Note that GRBL usually works well for the 1F.

I zero the laser by eye, mine is an Opt Lasers. Two options, depending on the situation:

  • the air assist nozzle is good approximation of the laser position. You need to find a similar physical reference on your laser.
  • I have written a small g-code (laser - minimum.nc - 210 Bytes) to fire the laser at minimum for 10s, it’s loaded on the controller and I never erase it from the menu such that it’s always available. :sunglasses:
    You may need to adjust line 7 and set a higher value to S (M3 S1).

I simply bring the laser to the bottom right of the panel. In the controller I click the position icon (not home) to set X, Y to zero.
Using the supplied height reference, I set the Z to zero as well. If Z is wrong, the laser will not be properly focused.

I have tried using the air nozzle with the probe, it works but is not worth the extra precision.

The bug that prevents firing the laser from MDI is not resolved yet :confused:

1 Like

Thank You,
I am using the Makita router, so I set up the laser as instructed in controller and leave it at that? Sounds good.

First you must purchase the laser module and install it.
In VCarvePro create your gcode file and send it to the controller. Turn on the laser and hit start. Make sure under tools dynamic power is checked.

1 Like

I have purchased the vectric laser module.
I have installed jtech’s onefinity laser post processor.

It seems to me that if there was a bug preventing it from firing I would have a problem too. I have no such problem. Mine fires just fine when you set it up correctly. What is the problem you’re having?

I wasn’t able to fire the laser at low power to zero a starting point.
I was not homing on boot.
I did have dynamic power unchecked.

What I needed and successfully added to this was changing pwm-min-duty to 5.
I was then successful at midi m03s12 command

Great to hear that you got it working. Now enjoy. It is a great tool and very versatile in VCarve.