Jtech Laser Controller Settings

For those of you who purchased (or provided their own) the jtech laser add on, as of Firmware update 1.0.9 and later, users no longer have to manually input laser settings. Select “tool” on the flyout menu. From the dropdown menu, select the “laser” option and leave “tool-enable-mode” on disabled

It is VERY important that you connect the control (black connector) wire to the control input on the
J Tech Photonics, Inc. laser board with the black dot. If you plug it in incorrectly, you will fry the laser port on our controller.


Also:

4 Likes

Hope there’s instructions or a video coming soon how to switch between router and laser. Thanks.

1 Like

under tool type, select none when not using the laser. when using the laser, switch back to jtech laser. That’s it!

1 Like

Hello my new friends :grin::joy:. So can you use the breakout board for the laser? I see that you have (tool enable-mode) disabled instead of (lo-hi). Are the pins used for the actual laser connector on the back of the controller (PIN 17-TOOL PWM and a GND)? I’m wanting to explore using a different laser module and get a feel for things and $650 is just out of my price range at the moment. Currently my IOT relay is on PIN 15 and PIN 25 but if those are the pins I need to use for a laser I’d just simply have a switch that I can turn on and off to switch between laser and iot relay that way both don’t try to turn on at the same time.

Yes, 17 and a ground.

1 Like

So in theory, I could have tool enable pin 15 still set up for (lo-hi) and ran to the IOT relay, pin 17 on laser pwm and just have a simple switch to turn off the laser or iot relay by breaking the wire to either one. Hmmmmmmm, ideas :thinking::bulb::joy:

1 Like

I’d be careful, auto turning on the laser can be dangerous!

3 Likes

Oh I agree. That’s why when I do this, I’ll be able to switch off the physical wires that go to either device depending on which operation I’m going to be using even if the gcode enables it. Saves me from having to use my fat fingers on the touch screen and enable or disable stuff. :joy:

3 Likes

Are you referring to the OF controller or the Vetric software? I just started using my laser and everything fired up just fine when I lasered a picture which came out great. Then I tried the laser cut and fill and it fired once as it started and then continued on without firing. I tried the picture again and it fired perfectly. But when I went back to the cut and fill it would not fire. Any suggestions?

Similar experience. Pretty frustrating. The cnc aspect works very well, but the laser not so much.

Did you get the laser with the Onefinity, or is it a salvage from another CNC? If it is a salvage, I had to contact JTech to get a resistor changed out, as the Shapeoko3 used different voltage levels to control it.

1 Like

are you using the LASER post processor from the files section to do vectors? If not, start there.

Support, you are correct. I forgot to change the post processor to laser. It now works great. However, I find it would be very helpful to add a minimum z height on start. I have crashed it twice because it doesn’t lift up when it goes to xy 0 before it starts. I have a fence at xy0 home to position my workpiece and because the laser sticks so far forward it overrides the fence when it returns to xy0. I have to remember to manually raise it before it crashes. A minimum z in the post processor would fix that.

4 Likes