Jtech Laser Mount installation and focus

This is what the mount for the laser will look like when you receive it.
You will attach the mount using the 4 bolts to the front of the spindle mount.
Attach the mount so the visible magnets are facing the back.
Then place protruding bolts on the back of the laser head casing into the two tiny holes on the mount. The laser should magnet into place. Focusing the laser is a simple as moving the Z height up and down.

Best practice is to raise the laser as high as possible in the adjustable mount by sliding the mount up in the vertical slots. The higher the laser, the less ‘wobble’ will happen when using the laser. (pictured is the laser in the lowest position)

Proper focus is having the bottom of the laser casing 1/8 from the material. (it will included a focusing acrylic spacer)


How do you zero the laser, say if your lasering on top of a carve
So that they are in alignment

use the command in the MDI tab to turn on the laser at very low power (1-20) out of 255 power. so if your spindle max speed is 255 issue a M03 S02 command and this should turn on the laser at low power if it is not bright enough then turn the power up a little with M03 S04.(continue going up until you see a visible beam) then use the light from the laser to set zero. When you are done you can turn the laser off with M05


Out of curiosity, can you publish the nominal center to center distance between the laser and spindle/router? In a perfect world you could offset your x/y zero location by that amount right? Is there a lot of variability from bracket to bracket or large tolerances in the bracket mounting to make that center to center distance just too unrepeatable?

That’s a good point. A more advanced use could be an offset. They should be very close…but when your talking laser beams with thickness smaller than a hair, close might not be close enough.


Yeah, this is true. I was sitting here thinking “Which is more accurate? A known offset between a spindle and bolt-on laser mount or eyeballing a laser dot on the corner of a piece of material.”. I have no clue which is closer!

I’m trying this manual low power MDI without success, using Firmware 1.0.5 I just don’t see any light when I click play.

The auto file fires the laser fine, starting with commands:
; LightBurn 0.9.16
; GRBL-M3 (1.1e or earlier) device profile, current position
; Bounds: X-0 Y0 to X68.36 Y16.13
G00 G17 G40 G20 G54
; Cut @ 60 in/min, 80% power
; Layer C00
; Cut @ 60 in/min, 80% power

There seems to be an issue with the base buildbotics code sending mdi m3 commands. If you reboot your controller and send it first thing, it will most likely fire. Then if you jog it around it seems to ‘loose’ the ability. Use this code in mdi: M3 S10 See if it fires the laser. M5 will turn it off. Then try jogging it around and retry to fire the laser. It would be helpful to see if this is repeatable on other setups.

I booted, cancelled the Home, and the M3 S10, M5 worked fine. It seemed a bit too bright at 10, but S0* seemed to not work. I used the controller joysticks to jog XYZ and it continued to work. Running the lightburn job worked, however results in MDI commands no longer working. Hope that helps.

when you reboot does it start working again?

Yes it works after reboot. Correction, I can see M5 S08 fine.

1 Like

Looks like every laser is just a tad different. S10 was perfect for our test one, S8 is good for yours.
It’s a bug we’re looking into.

i am having a problem with the MDI commands as well. The laser works fine with gcode generated from the post processor but will not respond the the MDI commands

if i reboot the machine and do not jog it the machine will respond the MDI command?

1 Like

reboot the machine, and move to where you estimate zero is and try mdi command to fire the laser.
We’re trying to narrow down the cause. It’s seems to stop responding after different commands. We are working on narrowing down the cause of the bug.


I rebooted and moved the laser to the approximate zero position and the controller turned the laser on with the MDI command of M3s10. Then I moved the laser again and sent the MDI command and it turned the laser on again. Then I homed the machine (all three axis) and the MDI command would not turn the laser on.
I rebooted and the MID function worked as before but then I homing Z and it again would not turn the laser on with the MDI command.
I rebooted and repeated steps one and two and the MDI worked but as soon as i homed any axis the MDI command would not longer turn on the laser.

1 Like

Thanks Stephen! That’s very helpful feedback! I’ll forward this to the dev team.


Is there any progress on resolving this bug?

1 Like

Nothing has been released yet. The work around is to not home the machine. Then you can input the mdi codes

Yes, but that only works once without rebooting the machine. After I do one burn, I have to shutdown and reboot if I want to relocate zero for the laser.