Laser moves away from workpiece at start of burn

I have been messing around with the 7W J-Tech Laser and Lightburn and come across an issue I can’t seem to find an answer for…When I start the job, the Z axis moves away from the zero point for the burn. The laser fires and on occasion I can get some ugly burn but it isn’t consistent and is generally between 0.25in-1.5inch away (on top of the 1/8th from the provided spacer). I know it is a setting somewhere but I can’t seem to find it.

Lightburn 1.0.04 - Device settings: 32x32, Enable Out of Bounds, Return to Finish, M8, 255 S Max

Onefinity v1.0.8 - Tool: PWM Spindle, max 255, min 0, pwm min 1, pwm max 99.99, pwm freq 1000, rapid auto off check, dynamic power check

UPDATE: Added images to show what laser is doing

Setting zero in Z axis

Laser running very high

Height of laser

As I mentioned above, this is an inconsistent height…I’ve seen as high as 1.5in…this example is 0.35 above Z zero setpoint

Hmmm… there’s an advanced option to add a lead-in (and/or lead-out). This gives the laser time to stabilise before performing the actual cut. The software attempts to put the lead-in outside of your part but it’s sometimes tricky to find a good angle and length for the lead-in.
And it does not look good for engraving, it’s mostly useful for cuts.

Could it be that you have activated the option?

1 Like

It took me a minute to even find that setting option. I am having this issue with Images (generally running threshold or dither style), and fill for lettering. I could only see that option for Line (not selected when I was going through the choices).

For Fill, there is 0 ramp and no Flood Fill. For Images, there is not advanced option available.

Here is an example of the image setup. The power and speed aren’t set as I haven’t been able to run test pieces yet.

OK. So, I’m still new at this and will call it noob mistakes. I had 2 errors in my setup which contributed to the issue.

  1. I was zeroing Z first and not last. There is nothing in the g-code to tell the CNC to go back to Z zero so this was mistake 1.
  2. I had Z control enabled within Lightburn. This was moving the Z axis even if I zeroed correctly.

Once I removed both of these mistakes, the issue has gone away. I will leave this post up (assuming the mods do too) to help the next person who is new and making these simple mistakes.

1 Like