Machine "stuttering" with Lightburn

I decided to start this thread as I first posted in the firmware update. This is not, as far as I can tell related to the firmware update at all.
To recap; when using Lightburn with Jarvis, stucki, or ditther options the machine “stutters” (the best description I can think of) as though something is binding up.

I have changed scan angle from X axis and ran it in the Y axis, but had the same problem, just now it was on the Y axis. I have tried several different photos, and settings in DPI as well and even trying to scan at a 45 degree. I took the same photo and through it at Vetric as I have their laser module and set to ditther with the same line spacing and ran that file with zero problems.
I have reverted to the previous firmware, then back to the newest firmware as that was not the problem.
I have at this point proven (to myself at least) that the problem is not the machine, or the photos. I sent an email out today to Lightburn support with a copy of the gcode file that Lightburn made that was giving problems. Now to wait for a reply.

Hey Rick,

You might want to check out this video posted by the 1F team.
I remember reading a post on this forum with a similar issue as to
what you are having. I believe there was a problem with too slow
of a speed setting or mm to inches mixed up.
I hope this video helps you out.

Cheers,

Neil

2 Likes

Didn’t know about the updated video. Thanks!
I gave it a watch, but doesn’t help.
I had been running at 35 and 40 inches per minute with out issue, now there is issue. I have been burning tiles. Even switching to metric to try and make sure there was no conversion issue did not help. I went back out this evening and tried at 70 IPM, but had the same problem.
Using the Vetric Laser module set for ditthering at 40 IPM for speed I have zero issues. I reduced the speed in Vetric down to 30IPM and it ran with no problems. It seems there is something here that I am missing, but for the life of me I just cant figure it out. I’d be happy to try and send one or two of the files I am using to see if anyone out there can figure it out, or see if it is just me missing something.

I am having the same issue, the only way I can get mine to work is by making the file smaller. By changing the DPI. However, that’s not the way I’m wanting it to look, if you find anything out, please let me know.

I think I might have an answer. I think it might be a RAM (memory) issue with the laptop being used. Mostly not enough RAM. I have a little stand alone laser, the D1 from Xtool that I also use. Using Lightburn I noticed that I was getting stuttering with it as well on some files, but if I lowered the DPI it would stop stuttering and run properly. My leading theory right now is the higher the DPI, larger the file, the laptop is running out of RAM and struggling to keep up. I am going to try this out with an older laptop but with more RAM to test it out sometime in the near future.
Keep in mind, I may be completely wrong about this. lol. This is just my theory.

I load my files with a jumbo drive. But I think that’s the problem

I am now having this same issue with trying to burn with Lightburn. It was doing it a month ago then stopped without me changing anything. About 2 weeks ago I did change my jerk settings to Mitz’s recommendation of 15,000. Now it did it again while doing a test burn. I wouldn’t mind it so much except each time it does it, it loses/changes the X and Y home. I decides to let it run and it did it again about 10 minutes later.

1 Like

I think the obvious first thing to do is return the settings to factory.

1 Like

This was happening before changing the jerk settings. Nothing else has changed and it only seems to happen with lightburn.

It only happens with my machine when using the laser, everything else works without jerking or losing it zero. So, my thinking it has to be something between the laser and the controller.

Agreed, I’ve never had this happen when using the router. I’m wondering if it would still happen if I changed the controller to router (I move it over to laser for laser operations) and run the same file.

Let me know if that works Please.

So these are the tests I ran today.

Re-ran same lightburn file - stutter
Same file but switched Tool to Router- Stutter
Same file but created in VCarve - no stutter
Ran new lightburn file - no stutter

So given that, I have no idea what caused it or how to avoid it in the future. I don’t know enough about gcode to know if the program created something the machine didn’t like.

One thing I found interesting, that file in Lightburn took the computer about 12 minutes to process before it would let me hit start. The same file created in VCarve took about 20 secs to process.

Update.

So I did a whole bunch of laser work this weekend after re-downloading the Laser Configuration to Lightburn and changing S-Max to 1000. I ran about 35 small jobs of svg files, all went great. I did a couple of image burns and I still haven’t figured out what the right settings should be so they looked terrible but there was no stuttering during those.
I then re-ran the Trial file without changing anything. It started stuttering again at the same spot, which is about 30 seconds into the third picture.
So, it would seem that there is something wrong with that file though I have no idea what it could be. I made it the same as other trial files I’ve made which is to copy/paste the first image a few times then select each one and change the speed/power settings to see which one looks best.
I’m giving up on burning images for now but I will come back to it in a week or two, once the frustration goes away.

BTW, after I ran everything I realized that I still had the tool setting on Router, rather than laser. Everything still ran great other than that one file so I wonder if it even makes a difference.