Major machine chatter in x and y when cutting circles

Has anyone experienced chatter when cutting an internal circle? I was cutting a concentric circle and a counterbore using a pocketing tool path and the machine starting chattering severely. I thought maybe a dull bit or feed too fast. I changed to a new cutter and iterated the feed speeds with no success. I did a test of a square pocket and had no problems? I have checked all fasteners and all are tight? NEED HELP!!

also the steps in the photo is the movement in the machine as it started to chatter.

Is it doing something like this? If so, it’s been discussed in a couple threads. Not sure if anyone has pinpointed the exact problem.

I was having the same problem when I was using the inches post processor from vectric, It was a pocket circle too, something like yours! Then I started using the mm one and the problem was no longer there. I was also using gcodes from Easel and there was no chatter/missing steps at all. Prior to that, I checked all my wire connections, a loose wire in the plugs can also make that happen.


thanks, Ill try using the metric post processor.

1 Like

We identified an error in the Vectric post processors that introduced chatter. Please delete your onefinity vectric post processors, restart your computer, then redownload the vectric post processors from here (we over wrote the bad ones):

and reinstall them to vectric. The issues of chatter in circles should be gone.


No problem, I hope it works for you!

Does that mean you can’t probe with the plate? I find that using mm there is no problem so why change the post processor?

you would probe before you ever load the file.

I had the same problem and solved it by going to raster cut with finishing profile. After reading this thread I downloaded and installed the new post processors and thought I’d give it a test. Using a piece of soft cedar I cut a series of 98 MM pockets 7 MM deep in 3 passes each as shown in the photo. Pockets 1, 2 an 3 were modeled in VCarve Desktop with the units set to metric; Pocket 4 had the units set to imperial. All were cut with a .25" upcut endmill with the router at ~13600 RPM, feed rate at 360 in/min and plunge rate at 175 in/min. Pockets 1, 2 and 4 used the inch post processor. Pocket 3 used the MM post processor. Pocket 1 used a conventional cut offset path. Pockets 2, 3 and 4 used a climb cut offset path. There was no chattering for pocket 1. However the chattering returned for pocket 2 when I switched to a climb cut. The chattering disappeared when using the MM post processor with a climb cut on pocket 3. The chattering reappeared when modeling in imperial units for pocket 4 and using the inch post processor with a climb cut. After all four pockets were cut, the Y zero point had shifted about 3/4" in the negative direction.

I reran my project last night using the mm post post processor in vcarve. I ran 8 different counter notes with no chatter.

I am having the same problem using Fusion 360. I tried post processing in metric but it did not help. I hope I can figure this out

I believe this issue has been resolved with the latest beta firmware update. @OnefinityCNC can you confirm this was addressed with:

“Reduce Max-Velocity from 12.75 to 10. Some machines lost steps with rapids being so high (mimicking bad wires)”

with the new post p and 106 beta, it should be resolved.

Is it safe to assume those of us who are still waiting for our machines will receive them with the latest firmware or will we need to update it when it arrives to fix this issue?


OneFinity updates their machines to the latest Firmware before sending them out. With that said if the patch comes out while in transit you would need to update it.

Good news is the update process is very simple and straight forward. Once you do it the first time you can click the “auto-update” and it will handle updates automatically.

Hope that helps,


I received my machine on 2/5/21 it DID NOT have the 106 firmware it had 105. I have also seen on the Facebook forum that others have received machines with 105. And yes I am having trouble with chatter while cutting circles, I changed to the mm post but still chatter I will update the firmware next.

As far as I can tell 1.0.5 is the newest firmware as of Feb 7-2021. Version 1.0.6 is currently still in beta and not a final release. Beta versions are a “use at your own risk version but please let us know what issue you have so we can fix it before final release”. V1.0.6 comes with its own issues but works well for most at the moment. Hope that helps.


As Christian just mentioned. Machines are shipped with the latest “Release” software. Beta is never shipped in any industry on production machines or computers. Until a software is out of Beta there are too many potential issues.


I should of thought of that on the firmware sorry, my issue is ver similar what is shown in the original post of this thread and like that described in “the weirdest bug ever” in the troubleshooting post. I was counter sinking some holes at .680” dia no issues,I then realized I needed a .750” changed my drawing and p and saved new Goode, ran the program and the chatter begin. I changed the size to .780” and still have the chatter.

I have not updated firm ware yet should I?