Shaking on GCode from Fusion

Not sure if this should be here or the troubleshooting category, but I think this is Fusion-specific…

I started the work on my wasteboard by making some 2D pockets in Fusion 360. When I try and cut them (even in mid-air by setting the Z0 high to test), the machine jerks / shakes pretty violently on the circular portion of the cut.

Here’s a quick video of it.

This sounds similar to this post

If I change the operation to a 2D adaptive clearing, it works fine. Is there something I can set (either in the operation or the post processing) to fix this?

1 Like

Joe try changing your post processor, I use Vcarve Pro had the same issue, change my PP from .in to .mm and it has worked ever since…

What was your cutting speed set to? I don’t know exactly what I changed on mine to eliminate the vibration (don’t recall what type of cutting operation I used before vs. after) but I definitely slowed down the feed speed and I no longer experienced the issue.

I’m assuming it has something to do with the two Y motors not operating at the same identical speed and it trips over itself, but I’m certainly no expert.

Hi Joe - welcome to the forums! Recommend posting more details about your operation - type, feeds, speeds, depth of cut, etc. As Eric mentioned, he slowed his feed rate from 150ipm to something less (like 60ipm) and the problem went away. Though I’m hoping the machine can cut properly at higher feed rates like 100ipm - that is a sweet spot for most cutters in the 1/4" range. Wade’s response of using mm is an interesting recommendation as well - I’m curious if there is a resolution issue using in?

Finally, recommend using a bore operation for the holes, or at least a regular 2D pocket rather than adaptive. I did my first real cut with my machine this weekend and aside from the OF going a lot slower than I thought it should, everything cut well. Still have some tuning to do though before the next big test.


I am planning to purchase the OF. I am curious when you describe it cutting a lot slower than you thought, is this because you lowered the feed rate, as others have suggested, or was there another issue. Happy to hear you were pleased with the cut quality.

@TMToronto - I don’t know the cause yet. The simulation in Fusion said 7 mins and is always fairly accurate with the my X-Carve. The cut on the OF took 17mins - again, far longer than I anticipated.

Possible cause could be I used the carbide post processor instead of Buildbotics since the OF is not available for Fusion yet. Although the machine was getting the correct G-code, it didn’t appear to be moving as fast as the X-Carve did when I ran tests before installing the OF. I have not looked at the balance of the gcode to see why is was moving slowly. If I can’t figure out the cause I will post here for help - too early for that since I haven’t spent any time looking into the issue yet.


Thanks all for your suggestions!

I have not had a chance yet to try changing the PP units as @Wade suggested. That will be my next item.

@cyberreefguru - Thanks! I would have attached the gcode, but I am too new here. I don’t have it in front of me, but as mentioned above it was a 2D pocket at 40ipm and I believe a helix going down @ 5deg and a .125" DOC. The shaking appears in the circular portion of the cut, not in the helix going down.

Dear Joe,
This is my first post for the OneFinity forum. I too am having the same problem when I use Vectric Aspire to mill dog holes for my wasteboard. I get a severe chatter when trying to mill a pocket ( a 3/4" hole) when using Aspire. It only happens during about 1/4 of the circle and then only on the outer rim of the hole, and I get a ragged edge. Also, it stutters even when there is no load on the bit, and it loses track of where it is. When I run the same procedure in carbide create and use the Shapeoko (*.nc) code it runs fine.

1 Like

Richard - welcome to the forums! Can you post your gcode? Just curious if this is a speed thing, or something else. Both problems seem to be related to rapid spirals, so that might be acceleration, feed rate, or maybe something else.


joe, send an email to . I have something i’d like you to try.

I had the same problem using Vetric Aspire. I contacted Onefinity customer support via email and they got me fixed up. Something about using the inch pp. They told me to switch to mm pp. Once I did it ran perfect. They said it is something that they are working on. I would say to contact them and let them know. I may be wrong, but I would say the more they know about this the easier it will be for them to get it figured out. Also, even if it’s though email, they will get back to you fast.

1 Like