Fusion 360: "alignment" problem in CAM

CAM newbie here so I hope this is a very simple mistake but… please help!
I’m trying Fusion 360. I designed a simple part (see below) but when I try to mill it I get absolutely dreadful (and very confusing) results.

This is the part:

fixation.stl (32.5 KB)

and this is how it mills:

It appears that each pass shifts to the left, as if the router somehow failed to return to its starting point.

I have tried different settings and they all fail with a variation of this problem. The above is configured for multiples passes and the post-processor provided by 1F.

I don’t know whether it is relevant but all the G-code I have generated with Fusion appear very aggressive when I compare to Carbide Create or MeshCAM. The machine trembles during the plunge moves.

So, I’m very confused, and would welcome any help/pointer/indication.

A lot of folk had similar slipping issue before applying 1.0.8. Also need to enable circular interpolation in fusion. Search forum to know how.


I had similar issues and found that the newest Post Processor on the Fusion Web Site helped fix a lot of the issues.I was also told (Fusion Technical Support) that it helps to have Smoothing and Feed Optimization turned on.

I have it on my list to see if there is a difference when those are on or off, however I have not tested it yet.

You can find the Post Processor from: Post Library for Autodesk Fusion 360 | Autodesk Fusion 360

I am currently using 1.07 of the firmware, and while I was given 1.07b from OneFinity that should have fixed the problem, I was able to solve by using the post processor update.

The post processor on the autodesk site should not be use as is, as it has circular interpolation disable. I experimented myself and onefinity also post about that. You need 1.0.8. I participate on the beta test. 1.0.8 fix the problem you have. But if you enable circular interpolation the toolpath will be smoother has it enable G03/G04 and do arc movement instead of stair like linear movement only.

I forgot the other thing. Once you you have the processor you can change setting.

I was using an older version of the PP and it did not have the ability to change the settings. After I installed the new version and changed the settings + used Smoothing and Feed Optimization, everything worked great.

I would recommend you update the PP, update to version 1.08, and use Smoothing and Feed Optimization.


1 Like

Use this one

This morning I have updated to firmware 1.0.8 and used the post-processor @blaghislain recommended to enable circular interpolation and now the layers are properly aligned.


I don’t know whether it is relevant but I had manufactured a version of the same piece with Carbide Create and I noticed that the movements were much slower, this is from Carbide:


And this from Fusion 360 (before I lowered the speed):

N45 G1 Z7.01 F2388.4

Both in metrics:

N15 G21

Yesterday the machine was making… worrying noise as it was cutting at that speed. I have lowered the speed in Fusion before trying again. Fusion cutting path is very different, more curves, than Carbide plus it was cutting aggressively due to the misalignment so maybe I’m concerned over nothing.

As a newbie, it does not help me that Fusion 360 has many tools pre-configured but I could not find a settings for wood. More Googling ahead, I guess :face_with_raised_eyebrow:

Anyway, this problem is resolved. Thank you very much. It’s great to have this help as I’m discovering CNC machining!

I don’t know why fusion has not generated a toolpath that use arc movement (i.e. G03) for you.
Here is a example of a simple pocket with round corner (same toolpath I used to test without and with circular interpolation (CI) enable.

  1. Settings
    • Left has circular interpolation (CI) disable.
    • Right has CI enable.
  2. Speed and Feed (see green square)
    • Left and Right have 24000 rpm
    • Left and Right Feed have 7315.2
  3. Movement (see purple square)
    • Left (without CI), only G1 linear movement used (XYZ)
    • Right (with CI), use G1 and also G3 (arc movement with XYZ + I + J.
  4. Number of gcode lines (see red circle)
    - Left (without CI), 3405 lines
    - Right (with CI), 886 lines
    The right one run realy smooth.

It did generate G3 further down in the toolpath.
At line 45, it is cutting the flat part on the edge of the piece.

1 Like

I thought I would share the result. Thanks again for the help.

1 Like

thanks for the answer! it’s helpful and useful.
I began to work with Fusion 360 and I gained a good command of it.
I have a XP-Pen Deco 01 V2 drawing pad , it works as a mouse in Fusion 360 but does not activated it, does anybody know why ???