Probe X, Y, Z change to mm from inches

Yesterday I was using the onefinity and the initial probe xyz worked as normal, and is set to be in inches. I was using a .25 bit and worked fine.

I started a second job, load new file, and did a new probe xyz and it came up in mm. It defaulted to 6.35mm, which I appreciate is .25 inches, but it was a glitch I had never seen before.

Today when I started the machine, first probe was back to inches. I will be doing a second probe after while, so it will be interesting to see if it switches to mm again.

Anyone experienced this?

Thanks! Bill

I believe mine always reverts back to mm…

It’s the first I have experienced it.

Bill - I think the controller defaults to metric. That said, the gcode should set the mode for that job, but might “reset” the controller after executing. I think M30 or M33 “resets” the job (I remember reading about that in another thread).


I had this issue, Tom is on the right track. The probe routine calls M70 to save the current state then a G21 which sets the units to metric and then calls M72 to restore the state from calling M70 but it doesn’t seem to restore the unit to imperial. I think I added a G20 to the probe routine which resolved that issue but in the older code versions there were other issues with running in imperial so I just went to metric for the CAM workspace in Fusion and called it a day.

In theory you could convert the G38 and G92 commands to imperial values in the probe routine and remove the G21 as well.

I figured it out thanks to you guys mentioning the G20 and G21 sets.

I updated VcarvePro yesterday, and when doing that, some of the defaults were not there, or at least settings used during the last file. One of those was the post processor selector. I inadvertently selected the onefinity (mm) post processor. That was adding the G21 (metric) code. I did a quick test tool path and selected the onefinity (inch) post processor, and the G20 code was there.

I had noticed when the job with the G21 code started running on the onefinity, the display setting switched to metric from imperial as soon as the job started, so it made me also think that it was something in the code, not the controller itself.

So… it was selecting the wrong post processor. User error.

FYI, and thanks for the help!


1 Like