Remote Controller Support

Has anyone used or tried to use software like Octoprint to remotely control your OF Controller?

1 Like

You can just use a web browser to “http://onefinity.local” and open the control screen on any PC that has a network connection to the machine. I connect from a laptop in my shop to do the majority of my work on the 1F.

Hi Mike I do that also when I’m at home or in the shop with access to my local network. I was/am looking for solutions when I’m away and don’t have local access. In the 3D print world there’s an app called Octoprint that allows truely remote control of the 3D controller


Even if you find a way to controll your CNC while away from home, I would strongly discourage doing so. There is a lot that can happen during a CNC opperation (broken bit, something falling into the work area, your gcode was not as good as you thought… the list goes on). While I do run my machine then go inside for a bit, I run out and check on it every 20min or so to make sure everthing is okay. PLUS I can hear my machine at all times, which when something goes wrong I typically hear it.

That said you most certainly can do as you wish, but I would be remissed if I did not state the potential downside of offsite opperation.

Good luck!

You could always VPN into your home network to gain access. Also, others have used an IoT relay as a “remote emergency stop” mechanism.

There’s not much you can do remotely other than stop things…

I just got my 1F setup and onto my WiFi network. I setup my DHCP server to assign a static IP address to 1F so I know what the IP address is all the time. The problem I’m having is that I cannot open a web browser to 1F using the IP address or the URL you posted. I can’t even ping the 1F from the network. I did upgrade the firmware to the latest version (v1.0.8 ). Any suggestion on getting this to work?


ensure your router/extender is within 10 feet with clear line of site of the controller.

Hi Skip,

If you can’t ping the address, then something is wrong with the network between your laptop and the 1F. I would double-check that the 1F displays the right IP address on the main control screen. My guess is that either the 1F didn’t talk to the router correctly, or it’s not picking up the IP address you think it is.

If the 1F doesn’t display the right IP - turn it off, reboot the router, then turn the 1F back on. If the IP address doesn’t show up - then you have something set wrong there.

If the 1F displays the right IP address, see if it can reach the internet (check for a firmware upgrade). Double check that the 1F and your laptop’s IP addresses are the same for the first 3 numbers - only the last number should be different (for example: - only the .yyy part should be different).

You can also hook up a USB keyboard, and get into a terminal window on the 1F. Using the keyboard, hold down the Control key and press the “t” key followed by the “c” key. (Control-t, Control-c) This should open up a new terminal window. You can then try to ping the router from the 1F to ensure those 2 can talk to each other.

Good luck chasing it down!


It’s really strange.

As you suggested, I connected the USB keyboard and got into the terminal mode. From there, I can ping my router and my Linux server. However, I can’t ping either my Mac or Windows laptop. Both of these machines are on the same access point as the 1FN.

I ran iwconfig and the signal strength on 1FN is -69dBm and I can run curl to an external web site (e.g., I’m at a loss here.


Well, it’s good that the 1F sees the router, and connects to the internet - so you have good wifi connectivity. So if the 1F and laptop can’t talk to each other - but both can ping the router - then the router configuration is where I’d look. Maybe go back to a vanilla DHCP setup - no static routes. Make sure the 1F and the laptops are on the same logical network (the first 3 numbers of the IP addresses should be the same). Double-check firewalls also.

Before I retired in June of this year, I was a network engineer. I thought I’ve seen everything. This is the craziest bug I’ve seen.

Removed the static IP assignment on my DHCP server. rebooted the firewall and the router. Removed all firewall rules for the LAN segment. 1FN has a new IP address now and the same behavior. I can ping 1FN from my router/firewall and my linux server and vice versa. Can’t ping 1FN from my mac or PC on the same subnet.

Waiting on 100’ CAT6 cable to come in from amazon so I can hardwire this stupid machine and see if I can make it work.


Is ping response being muted? (it’s a common anti-phishing/security setting)

I don’t believe the ICMP messages are being muted. From the Mac and PC, I can ping my router and the linux server. To make sure my WiFi access point is not the culprit, I pinged my iPhone from both the Mac & PC they both worked. Just can’t ping the 1FN.

Some router/wifi setups will prevent one wifi client from communicating directly to another wifi client - there might be a security setting somewhere to control this in your wifi access device.

Try looking at the arp table on your device instead of using ping, arp isn’t subject to host based firewalls the same way. To do this you need to initiate some connection to the 1F controller which could be ping, then use arp -a from a command prompt. You should see an entry for the mac address and IP address of the 1F controller, if you do not you have a wifi/physical type issue. If you do you have a host firewall/filtering issue.


Derek, you are a genius. Never thought to check the ARP entry. For whatever reason, the Mac and the PC are not resolving the IP address to the MAC address of the 1FN WiFi interface. I manually added the ARP entry on the Mac and it’s all happy. Thank you. I was pulling my hair out.


No problem, glad you got it sorted out.

I’m a network architect and I deal with strange and unusual problems every day :slight_smile:

1 Like

Glad you got it to work! Really strange that you had to edit ARP settings - but whatever it takes I guess. You’ll like being able to connect this way - i rarely use the touch-screen monitor on the 1F anymore.

Noob here with no network experience. I’m having a similar issue (I think, see attachment) but don’t fully understand how to do what you are talking about. What would the complete command line look like?

It’s likely there is a setting in your router that is preventing it from forwarding arp requests as a security feature. Adding entries to the ARP table should be unnecessary to do.

“arp -a” will display the current IP to MAC address bindings. In your case you should see an entry for

“arp -s” will add a static entry (must run cmd as admin). To do this you will need the MAC address of the Onefinity controller (you can probably most easily obtain it from your router DHCP table or by looking at the ARP table on the router). The command will look something like “arp -s 01-23-45-67-89-AB” where 01-23-45-67-89-AB will be replaced with the MAC address of the Onefinity controller.

Thank you!!! I will give it a try.