Spoil board alignment woes - AND USB DISCONNECTED

pulling my hair out today trying to figure this alignment issue out. - the USB being constantly disconnected is almost as infuriating.

I decided to do a t-nut and dog hole method for my cnc table. i made a file in fusion 360 that looks like this

this way i don’t have to remove the t-nuts when i change out the waste board. anyway.
ran the file on my surface and it turned out fantastic - was pretty stoked.

slapped some mdf on the table, screwed it down and ran the files again after re-probing Z (these are separate gcode files for each)

lucky for me i was watching it because this is what happened.

dog holes are way off

whats odd with the t-nuts is the first 50’ish holes were perfect - then it just decides to do its own thing and the rest of the holes are slightly off - whats even more odd, is that the t-nuts and the dogs holes are not off in the same direction. who can explain that one?

these are the same files so it has to be something else other than the gcode - i do have some Ferrite Rings coming in today - maybe its that… but have ran it again a couple times and no change.

so this hole position in the X and Y in the MDF measures exactly what i have in the file i created… i looked through every version i created and i never had one with the dog holes in the position that was cut in the tablet top which means the original cut was the one that messed up and not this last version… which means i won’t know exactly what the dimensional difference between the first and the second so i can fix it to match the first run… well. this sucks.

still haven’t figured out the t-nut situation. but seeing as the first 50 were good and it shifted starting to cut it was either the first file again was goofed or the second, but can’t find anything in the file or my process.
i knew i should have just cut these all at the same time with a longer bit… lesson learned on that one.

1 Like

You mentioned the usb disconnect, but didn’t speak of it other than it’s constantly disconnecting. Have you tried other ones or physically smaller ones, is there a loose wire in the control box?

I’m scratching my head on your holes not lining up too. At first i thought the workpiece moved but you said you screwed it down… assuming what you screwed it into was made stationary.

My dog holes are only 5/8” deep and the dogs hold fine. Still suck for you but you could still use it. I think if you want to go deep you should cut through the spoil board and the board below in the same operation.


I have tried others. And results the same.

Will be checking that today. Haven’t opened up the controller.

My dogs are 1-1/4" long hence cutting through both but looking at shorter ones as you also suggested.
Which ones do you use?

1 Like

I didn’t think it was the problem, but it doesn’t hurt to ensure it’s been eliminates as the problem causing agent.
If it’s not a loose wire there has to be something exterior causing it, but finding us out what that is would be us throwing darts at the wall in the dark… unless it’s a bad unit. Those are the only things i can think of.

I may look at getting one of those button usb sticks like this. As it also happens when i move the screen out of the way when homing

1 Like

I use these which are also longer. I cut them down to size and it’s easy since they are plastic.

1 Like

Ha. Those are the exact ones i bought

I cut 3/4" dogholes which were VERY tight. I then added .004 to the diameter which made the hole tight, but I am able to insert and remove them by hand. So if you were to start with .754 holes those should fit right in. Best is to cut a test hole which I forgot to do.

1 Like

Thanks, good to know. I think i did mine slightly less than that and had to use pliers to get it out on the plywood. Luckily i only let my cut run for the first hole on the spoil board since i was already paranoid after my t track goof up.

I did do a test cut in mdf and it seemed perfect then i ran the same file and it was super tight but i also think that was the difference between plywood and mdf.

Thanks again.

My Masso had the USB not installed several times, I asked support and they said open it up and check the connections. Nothing obvious, but I went straight into an empty USB on the controller itself, and bingo!! instantly recognized. Wiggled both ends of the extender and then the exterior worked also.

The super tiny connectors at the exterior end can easily have corrosion and or dust that will stop getting a good contact for sure.

I had the USB issue on my Elite as well. I tried a port on the controller itself and that seemed to fix it, but it’s not an acceptable solution as my WiFi module isn’t working. I ended switching the USB stick and it seems stable now.

1 Like

@gszrir thanks. Will give it a go. I have several others that i can try. Havent opened the controller yet and haven’t figured out the wifi thing yet as that woukd be ideal.
Connects to my wifi fine but not able to find it from the masso link software. But also haven’t had alot of time to mess with it

The Masso link is the way to go in my opinion. download the Masso link software from Masso site.

1 Like

Don’t forget to type the IP address of the Masso into the Link software.

I agree, however if the USB disconnects while the machine is working it will still pause the job. He needs to get that connection stabilized.

I did put in the ip but never would connect. Could have been blocked by my router will have to dig into it a bit more.

But yeah the usb disconnecting and stopping the job happens almost every cut. Gets pretty annoying as you can imagine.