Stumped on getting Fusion360 file to router on ethernet

I can’t figure out how to send file from F360 to my router. I could use the dummy version explanation on what it takes. Any body

Right click the tool path, choose post process, save gcode, upload file to controller, cutty cut cut

Hi Steve - which part of the process are you stumped about exactly? BJ sort of nailed the workflow.


1 Like

Hi guys
I don’t see anywhere to hit upload file, and I am not sure what happens, do I see my controller on my computer showing that the file has been transferred there. Very confusing when you’ve never done it before or seen it done by anybody else step by step.
Thank you very much for the help but I couldn’t get it there yet. So trying to get something to cut, had my machine for over a month now with no success from using fusion 360

On the controller interface there is a folder button to the right of the play and stop buttons… You can upload from a usb drive (not usb3) directly on the controller or from your laptop if you connected the controller to your network by going to http://onefinity.local

This can be confusing. There’s at least three points to link together:

  1. Fusion CAM → gcode file (NC program) on your computer
  2. gcode file (NC program) from your computer → somewhere on Onefinity Controller
  3. Controller Display → Find the right file

Yesterday I forgot my flashdrive, so I was playing around with my phone, Dropbox, and eventually an SFTP transfer from Dropbox → Phone → controller.

Here’s my rough workflow:

  1. In Fusion create a “NC Program.” This isn’t strictly necessary, but it makes it easier to find on the computer. See (1) destination and (2) make sure it’s using the Onefinity post processor.
  2. Whenever I finish tweaking something, right click the program and select “Post Process.” Fusion should give you a notification that it saved. You can also right click the program again and select “Open NC Output Folder” to reveal it.
  3. Copy this onto a USB flash drive.
  4. Now fast forward to the machine. Turn on everything and plug the flash drive in.
  5. I grabbed a terrible screenshot of @cyberreefguru’s video, but you want to hit this folder looking button third from the left. This will open the file browser on the controller.
  6. Now for the extra fun bit. Find the flash drive in the file explorer. I don’t have a picture or screenshot of this, but you can imagine it’s a lot like Windows/macOS.
  7. Select the NC program you saved in step #3.

CleanShot 2021-04-03 at 09.03.52@2x

1 Like

Oh my main objective is to send G code from my computer to the controller on ethernet if that’s possible

I really appreciate your help, I get confused between sending by ethernet and using flash drives, I prefer ethernet. I just not sure how to post these files and see them on controller so I can run the file.

You can use an SFTP program to do this, but I don’t know how to do it directly in Fusion.

I’m assuming you are getting the gcode file (.nc) created OK from Fusion360. If that’s not true - read eaststreetcarry’s post again. Once you have the gcode file, turn on your 1F and from your computer open up http://onefinity.local. The screen will look exactly like the one on your controller. When you click the open icone (purple arrow above), you can navigate to a folder on your computer, select the generated gcode file, and it loads to the controller. All of this works without a flash drive. The only trick is that your computer running Fusion has to be on the same network as the 1F.

This is the only way I run files - I’ve never used a USB flash drive with my 1F.

You don’t connect from Fusion to the controller - there’s that extra step where you create the gcode file out of Fusion, and then load it into the 1F through the web interface.

You can copy the file to the controller without the web interface - but other than batching a number of files there’s really not any reason to.

1 Like

My problem is up load file to controller, not able to find a way to upload it to the controller, i’m using fusion 360. If anybody knows way to upload file to controller from fusion 360 it would be very helpful to me.
thank you for the information

Steve - AFAIK, there is no way to send gcode directly from Fusion 360 to the controller, either as a file or as a gcode sender.

You can, however, as others have pointed out, upload the gcode file from your computer to the controller over the network (assuming the controller is on your network). @eaststreetcarry details the instructions for that. Are you having issues uploading the file to the controller over the network?


Hi Tom
I’ve been trying to get some code to the controller, Computer is hooked up to the Internet so is the router, file doesn’t come up where you would hit files button next to the start button. The file that I finished, how does it get on the Internet I guess is what I’m asking, so that it will show up in my controller files.
I hope you can understand what I’m trying to do.
Thank You for all your help, again.
Ps what does AFAIK mean?

Hi Steve.

On the controller screen, top left corner, you will see the IP address of the controller. From your computer, enter that into your Internet browser location bar - Chrome is best, but any browser should work.

Once the OF UI is rendered on your computer, click the folder icon just below the touch pad (it should be directly below the ‘Message’ tab). That should bring up your file chooser from your OS. Locate your gcode file on your computer, select the correct file, and click “OK” (or whatever the button says).

Based on your last post, this appears to be where you are having problems – locating the file on your computer. The file will be where ever your CAM software saved it – I don’t know what the default file location is for Fusion 360; I save everything to a known location so I know where to find things later - I recommend you do the same.

Once your press OK, that should upload the file from your computer to the controller. The controller should automatically select the file. If you are using 1.0.7, you will see a popup saying the file is being processed. When it is done, the file should be in the drop down (combo box) to the right of the trash icon. To execute the file, click the arrow button (first button in the row) – it should change to a double vertical line. If you want to pause the file, click the first button again – it should change back to the arrow icon.

Hope this helps.


If you create NC programs (which save all the options, name, destination, etc.) for a particular setup/set of operations then you can also right click the program → select “Open NC Output” and it will pop open the folder with the programs.

Thank you thank you thank you!!
I finally got something to work that I expected, a simple file of a square 6” with a groove 1/2” inside perimeter 1/4” wide 1/4” deep and it worked. between the two of you we got this working, it still seems a little complicated but I keep going over and over making new simple files and out putting them getting practice of homing machine probing my work piece remembering to take off the probe remembering to start the motor and running the file with good results most of the time. sometimes I try to re-run the same file without changing the work piece to see if it would re-run it without a problem, at this point I started having a problem as it would not completely run the same program, all I did was push the start button and had some problems but I’m working on it. maybe you just can’t do that, I still have not got the new update, I cannot download it because I don’t know the password so doesn’t work I’m still on Version five. Any suggestions would be greatly appreciated on that.
I want to thank you guys for sticking with me on this I’ve been working very hard watching a lot of videos reading and it just didn’t work but now it does so I celebrated a long with Easter yesterday and it feels really good to now be able to proceed with creating files that I can actually cut.


Even on 1.0.5 you should be able to just hit play after a file finishes cutting and it should rerun over again.

onefinity or buildbotics should be the password (all lower case I believe). You can do the upgrade from a remote pc using the http://onefinity.local url in your browser if your controller is on your network.

I would suggest splitting your upgrade woes to a separate thread of they continue and searching other threads doesn’t help

Post a video of what you are doing while explaining what you expect. Typically the issues have been that my expectations were not in line with reality and the cnc did exactly what I asked. I just didn’t understand what I was asking. Often we miss steps that are very important when walking through issues. That is one of the things I love about the details that @cyberreefguru goes into in his videos.