Testing Run - Ran into a bug with Tool Enable

@onefintitycnc

I am using relays to power contactors to run my vacuum and Makita router.

With some great help here, my bench-test ran perfectly.

Once assembled, my vacuum would come on but not the router.

I am using pin 15 and Tool Enable Hi-Lo for the router. Testing from the control panel I used M3 to enable and M9 to turn off.

I am using Load-2, Pin 1 for the vacuum. I used M8 to enable and M9 to turn off.

Both contactors closed in the bench testing.

After assembly , the power for both the router and the vacuum are good because I have bypass circuits and both run.

When I noticed that the vacuum would come on but not the router, I swapped the wires running from the relay wires to the contactors. I then entered M8 and the router came on fine. So I know the AC / Contactor is working.

My first thought was that the relay connected to the breakout board had died… and that still may be the case. However I discovered something that may be amiss in the controller.

When I look at the I/O page and see the settings for the Loads, I see that next to the settings for Pin 1 (Vacuum) there is a black negative sign. When I hover my mouse over it it says Active False. I then go to the main page and enter M8. I come back to the I/0 page and see it is now a green plus sign. When I hover my mouse over it it says Active True. Entering M9 turns it back to Active False.

So then I go to the Tool page where I have Makital Router configured with Lo-High. There is a black negative / Active false icon there as well. When I entered M3 in the control panel and go back to the Tool page the icon is still a black negative and it still indicates Active False.

Thinking that it may be because of an open circuit on the output I shut down the system and removed the breakout board from the controller. After restarting, I tried enabling the vacuum (M8) and it changed to a green plus sign like before. To me this indicates that it doesn’t have to have a load.

Before I tear the breakout board apart and start injecting DC, I thought I would see if I am missing something. I ran searches through the forum but I didn’t see anything.

Thanks always for your help.

Hey Ziggy,

this may be this issue (activating pin 15 with M3 command only works with ‘tool-type’ set to “PWM spindle”).

Unfortunately I cannot test things at the moment because I don’t have the machine here.

1 Like

Thanks! I’ll read the thread.

It is odd that it worked on the bench though.

As a follow up: I emailed support and they said it worked on their end. But they added a s100 after the M3.

I tried this and it worked. I guess it needed a speed even though I don’t think I entered a speed the first time I tried it.

Maybe this will help someone else.