Help Controlling Router/Vac Auto On with Masso

Hey guys, so totally new to the cnc world and just got my foreman set up a couple days ago, awesome machine cant wait to get to a know it better! Anyways I feel like a dope but I cant get masso to power on my router (makita). tried changing it on the set up screen to pwm (assuming power with masso) and set the hertz to 60. every time I load a file it wont power it on. not sure if what it is that i’m missing but its got to be simple. Any help appreciated!

The PWM is only for spindles not routers. Just to rule this out is the power switch on your router in the on position? Can you turn it on manually with the MASSO?

1 Like

Thanks for the reply. Yes power to router is on. I’m not sure how to power it manually via masso, i just have it plugged in to its own power source
for now.

The router needs to be plugged into the back of the controller. The controller provides the power for the router and controls the on and off. Hit start spindle and the router should come on.


Yes I get this, and it does not. Here’s a couple screen shots, does that look correct? For the heck of it I checked the fuses and they look fine.

Caveat, I don’t use a router, but I think if you put the power cord for the Makita into the “router” outlet on the Masso power box, turn the router on, you would then go to the F2 Program & MDI screen. To the right of the “spindle CW”, put in a value such as 1000 (RPM box), then hit the Spindle CW button to turn on the router, and I think alternate presses turns it off.

Pretty sure you can’t power it on manually like that because it’s not being controlled by masso… your looking at the spindle settings which are not being used in your case. But if you really want to, you can try s18000m3 in the mdi… i don’t think it’ll work though

I would test it by plugging a fan into the router port on the back, turning the fan on, then starting a program with gcode.

Guys thanks for all the suggestions, literally tried everything you guys have said, had my hopes up but looking at the gcode it does auto generate the m3 command so I just don’t know. If anyone runs this setup I’d love to know how you got it to work. Thanks

Hey Bill,

are you sure you connected all cables between CNC controller and Power supply, and the router plug as described here?

And you know that for M3 (spindle control) to work, you need to have set S (spindle speed) to a non-zero value? E.g. M3 S10000? If S is unset or set to 0, on CNC controllers usually the M3 command will do nothing.

Router plugged into the router outlet, router on, any tool# between 1-99 or 100. It should turn on when you run a gcode.

You can’t control the router like you can a spindle (control speed with gcode), 2 different pieces of equipment.

1 Like

Thanks Chris, this is what I’ve got, seems all there to me but I could easily be wrong, am I missing something? Vac port gets nothing either. Contacted 1F to see what they say; will update once it’s figured out for anyone else that may encounter this problem. (But still open to solutions)!

I did try this with a value in the box next to spindle cw, just wasn’t in picture

Hey Bill,

I see you have S15000 M3, M8, and T1 M6 in your g-code which should be enough to make it work (I have no personal experience with Elite Series though).

With a Makita hand trim router, none of the spindle “VFD/PWM/STEP/DIR” settings have any meaning, also a Makita router cannot honor any of the speed settings (although you need to set S to a non-zero value) (however a milling motor like this one or this one with their analog speed control interface would work well with PWM mode (if Onefinity finally releases a 43 mm mount!)), and when using a Makita router, the M3/M5 spindle control is implemented only through the Onefinity Elite custom power supply sockets you see here:

Image 1: Elite Series power connections on power supply

On the left you see the U.S. version. Are you sure you have the third separate plug in the lower row connected to a 120 V outlet? Does there come out 120 V on any of the vac/router sockets?

Image 2: Elite Series control cables from CNC controller to power supply

Also as you can read in the document “Troubleshooting: Rail is getting hung, stuck, or out of alignment (x35/x50 machines)”, there are some tips on cable and connector checking, and the Onefinity Elite uses the same type of non-shielded control cables with similar tin-plated Molex/Amphenol connectors and also with same lacking strain relief as the Standard Series, so I would have a look at some defects like these:

and also follow the tips for these:

To check all of these cables/connectors, after having followed the tips from the manufacturer above which consists of reseating the connectors, inspecting the crimp on their pins, etc., and this leads to no success, I would thoroughly check them this way:

1 Like

I just set up my machine today and I am having the same issues. The machine will run the file but it wont send any power to the relay plugs for VAC or Router.

Hmm well the m08 is there which should send the signal… last thing i can think of is check the fuses.

@JonCug appears to be having issues too. Maybe there was something not connected with the batch, and that’s why…

The last step i would try is to run a code with a light or fan, or put a multimeter in there… process of elimination. See if there is power, or if it’s a issue somewhere from black box to masso

Hey all,

that’s what I also would suggest (besides the checks I mentioned above).

Chris my man literally checked the fuses and all the wiring before I even posted, then checked em again the other night when I was f ing around with it for like an hour. Was actually glad to hear I wasn’t the only one with the issue. Hopefully get a response from their support early next week and get it figured out. And yes all, fully aware the software won’t magically jump out and adjust the speed dial on the router, just want it to do the simple binary operation for which it was designed.


Did you email ? That’s the tech support email.

Info@onefinitycnc.con is for orders/shipping. They do not do tech support.

1 Like

Morning, Looking at this picture it’s hard to tell what stage you’re at but here’s my observations from the image and should you have done everything mentioned already I apologize.

  1. It doesn’t appear the machine is “homed” unless you’ve changed it to the top right corner;
  2. It appears as though you’ve selected “Rewind” but I’d hit it again…after you’ve homed the machine;
  3. Did you try to manually turn on the Makita by selecting “Spindle CW”?
  4. I personally have finger registration issues sometimes with touchscreens, try a touch pen and hit the “Cycle Start” button.
  5. My last thought and I’ve had issues with it also is to remove and re-seat the “A” Cable. I probably have a loose wire in there I need to rectify but it’s been a problem twice so far.

If you’ve done all that I’m out of ideas and hopefully it gets resolved shortly.


1 Like

They are sending me a new power supply.