Troubleshooting JTech laser

Hello there,

I’d like to ask for help.
My JTech laser lost all the power (and it is not the PWM change).
I did some cardboard cutting, but after a while, the job was not finished.
I thought that I had some dirt on the lens.
It looked like that - the light was scattered in a strange pattern.

I tried to clean the lens with isopropanol very carefully (I found such advice somewhere on the internet).

But it did not remove the problem.
The light is still scattered in that strange way.

Has anyone had a similar experience?
Does anyone know how to fix that?

It looks like your lens has cracked. If you have debris on the lens for a long time it will heat up the lens when processing and at some point the glass lens will fail and crack. You can get a replacement here:


Thank you very much for the help.

Since the shipping to the UK costs more than the lens itself, I’d like to ask you if it is a good idea to buy more of them - is this a common problem?

It can be. If you don’t clean your lens, then it will happen a lot more. Also, if you don’t have air assist, it will happen more.

Not a bad idea to pick up a couple, especially since it is going across the pond. :slightly_smiling_face:



Help. Cannot get the initial test fire for JTech 7W to go. Have tried MDI settings (M3 S??) tap play - nothing. Flip the switch on JTech controller to manual and laser fires. Have a file in Lightburn loaded on 1F…hit play and no laser but the program runs. Start it again, manually turn on laser and it burns the file but includes the tool path lines. Running 1F version 1.1.1. Have watched vids in Forum/FB/Instagram/YouTube and JTech ___ I’m stuck Standin’ on a corner in Winslow Arizona with nothin’ but JTech on my mind : /

Charles I’m having the same issue and and can’t get the M3 Sxx codes to work, after trying multiple time I restarted the 1F controller and no luck with the M3 commands and just for fun I hit play on my first ever file with Lightburn with success. I changed some some power and speeds in Lightburn to improve the file and ran the file again also with success but still no response from the M3 codes. I tried a different file and it didn’t fire ??