X axis homing issue. Loud movement (solved!)

I just assembled my X-50 Woodworker. From the beginning it didnt seem like it wanted to home the x-axis. It would take several tries. Sometimes it would stop short and think it homed. Other times it would tryto drive past the hard stop. I finally got it to work by rehoming several times. I was able to flatten my spoilboard and create a two inch grid. I am now part way through my first project and it paused for a bit change. Now the x-axis is very noisy. It will move with joy stick but not to rehome.

@Kwest2208 - welcome to the forums. That sound is certainly NOT normal. I’m guessing the ball screw is loose and needs to be tightened, but it is hard to tell. I would certainly reach out to support and get their input.


You might also check the axis cable/connectors plus make sure you have the latest firmware installed.

Thanks for the reply. After I posted, I did notice several references in the chat regarding loose connection’s so that will definitely be something I’ll look into. I’ll verify my firmware level as well.

Thanks Tom. Where is the ball screen? Do you have anything on your channel about it? I did email support as well.

Definitely a wire/connection issue not a ball screw issue…

1 Like

Sorry - ball screw. Damn typos.

Gotta love auto correct

It’s not a ball screw issue.

UPDATE Problem solved! I followed the troubleshooting steps from OF support and found that the nut on the end of the X-axis screw shaft was about 1/2 turn too tight. I loosened it until the washer behind it just barely turned freely and it worked. All nice and quiet. It moves and homes perfectly. THANK YOU ALL!


Nice first project :+1::+1:

Thank you. Had time to design while i waited for my QCW frame.