X rail not moving

OK guys, already emailed support but figured I would see if you guys have suggestions. Brand new machine, Onefinity forgot to pack the touch screen but got that taken care of. Hooked up the laptop.
Homed machine x rail only whirling and grind sound.
swapped m0 and m3 cables and same issue with x, z operated.
pulled stepper motor and observed it slightly move, and kind of bounce back and forth.
looked at plug end and pins appear to be in place, do not know how to remove this plug to check wire connections. Any of you guys can tell me how to do this? I read where on other post a wire off or loose connections caused this type of issue, just don’t know how to access back side. TIA

Ok I got a response from support in like less than 30 minutes on how to access the wire plug inside the X rail. Unfortunately that was not the issue, the problem was self inflicted by me. I will explain for those interested or think they can do what I tried. When installing my machine I also installed the drag chains for Y and X axis, also put the Y motors to the front for my setup. I purchased the cable extensions, but only for the Y motors. The X cable was not long enough, but there was another wire cable in the boxes marked “spare” that didn’t have the black mesh covering. Well didn’t matter because it would be hidden in the drag chain, so I thought. I discovered during the troubleshooting that the “spare” cable looked same as the one inside the X tube going to the stepper motor. Evidently you can not put 2 of these cables in series, evidently the phasing of the wires must change between the mesh covered cable and the motor cable, so when put in series they swap phase(for a better word) again. Both the cables worked fine individually. Asked support to give me a part number for a X cable extension, if any of you guys know, let me know. I am sure support will get back with me. Sorry for the long post, hope it saves someone else the trouble I went through today trying to use the “spare” wire sent for anything other than replacing the one inside the X rail.

Did you get a part number for the X cable, I had a similar problem?

Rufus, I didn’t get a part number, but it is the cable extensions they sell on 1F site in 2 or 4 ft lengths. They can be used for x or y