Z Axis Below Limit by nearly 2 inches

I’m fairly new to the Onefinity, but I’ve successfully cut out clamps, L-Brackets, and V-Carved a simple “Hello” all into 3/4 MDF or Plywood. Now I’m starting my first more complicated piece and I’m getting the dreaded z-axis error: "The current toolpath file would move 1.807 in below limit with the current offset. I’ve read all of the forum posts related to these errors and watched all of the videos, but still no luck. Such as "Help! My Toolpath says ‘Under’ or ‘Over”! (A FAQ on why) and the videos in Z Axis limits issue.

Here is what I know:

  • I have dog holes in my waste board and I can move my Z axis and bit well below the workpiece down into one of the dog holes, so I don’t need to lift it up. - Using the same bit and wasteboard, I can carve CAM clamps out of MDF using a different GCODE file.
  • My steps:
    1. Turn on controller, home using popup dialog (also tried clicking the Home All button afterwards). Machine homes properly.
    2. Use the probe on the left front corner of the workpiece to probe XYZ. I’ve ensured the probe is properly placed and the GCODE file expects the zero to be the left front corner, top of workpiece. I get OK in the table for X, Y, and Z
    3. Then I open the GCode file, it does the simulation, and the Z cell in the table goes from OK to UNDER. I’ve also tried loading the file before probing and the differece is that the Z cell stays at UNDER and never changes to OK after probing.
    4. If I ignore this and run the file, I get the attached error (which is expected considering the Z cell didn’t say OK).

Now, if I immediately load another file that I’ve already cut (such as my cam clamps out of MDF), the Z cell goes back to OK and it appears it would run fine.

So, I believe the problem is in my file. The job sheet shows
that there is no toolpath that goes deeper than .753 inches. It’s a .75" workpiece and that the .753 toolpath is to cut the outside profile. There are V-Bit cuts in the project, but the job sheet also shows that the deepest is .137". So there is no cut that would go 1.807" below the workpeice surface as the error indicates.

So what am I missing here?

a positive number means it’s going up, negative (like -133 and beyond) means down. Do you have multiple tools in the file? If so, separate each one into it’s own file.

Okay, yes I do have multiple tools in that file. I’ll put them in separate files and let you know if that fixes the issue. Thanks.

1 Like

That was the problem. Saving the project to multiple files (one file per tool) fixed the issue. Thanks!


I had the same problem today turn out I have set the origin position in the wrong place (using fusion360)