10.8" screen goes blank for a few seconds

I just setup a new woodworker X50. Works great except for the screen.
It boots up fine and screen stays on for first minute or so then starts to go blank for a couple seconds then comes back on for 30 seconds or so. This happens constantly no matter if the machine is moving or sitting idle.

I have seen all the posts and videos of connecting all the USBC cables properly and connecting the separate power supply. All that is done with no change.
I tried changing what electrical outlet and circuit the screen power supply is plugged in to.
I tried changing which USBC plug is plugged into which port on the screen.
I also tried another usb power supply cube in case the one shipped with it was defective.
No change from all of this.

Any one see anything else I should do?

I had the same problem last week. It was the first time that it happened or that I noticed that it was happening, and only when I was machining. I don’t spend a lot of time looking at the monitor, but this day I was doing some work beside the monitor and noticed that it would go out for a few seconds and then come back on. It only happened that one day and hasn’t happened since. Not sure what caused the issue. I checked all of the connections. Maybe it was something that was loose and I fixed it. I will pay more attention to the monitor in the future. It never effected the machine from cutting at all so I’m guessing that it is something in the monitor or cables to the monitor.

Yes, it does seem to just affect the monitor. I am just setting up my machine so I was moving the x and y axis for a few hours with a 2 foot square and dial indicator getting everything squared up. The screen going blank had no effect on the movement of the machine. Except when i was using the screen to jog it would not respond to my finger taps when the screen went blank.
I ran a program in the air afterwards and all went well. Screen blinking on and off had no effect on that.

Thanks Onefinity Support Leader.
I will go through those instructions again very carefully.

@ChrisM did you resolve this issue? My setup just starting doing the same.

Best,
_Mike

Mike,

Mine was fixed by replacing the HDMI cable. It’s been perfect since.

This happened to me twice today i have new cables. I usually don’t look but was watching today. Only happened since that last update.

Thanks Chris, I will change the cable and see if it fixes my issue…

I had the same issue. It was solved by adding a cheap Ferrite Ring to the cable. I also bought a new cable, but wanted to see if the rings helped first. They did, and I am still using the original cable that came with my machine. Hope that helps.

I ran into the same issue recently, in my case I believe the issue is caused by static electricity from my dust collection system. The issue only happens when running the vacuum and I’m working with high-dust material like MDF. I’m going to relocate my display and invest in an anti-static hose to see if that eliminates the issue. I’ve also had the machine stop with a curve error a couple times, but only when running the vacuum in the winter with dusty material.

Bit late to the party tried ring and also rerouted cable but no improvement brought a new cable mid range price and after 5 days no sign of a blank screen, feels like working with a new machine as it always seemed to happen at the worst time