Catch all Tray borders not symmetrical

Can anyone help me figure this out please. When I simulate the tool paths for a project containing a tray, the simulation is perfect. But when it comes to project time I have noticed some of the walls of the tray are thinner and not symmetrical. I probed the machine between every tool change. This has happened to me a few times. Be gracious with me a nube and I’m not tech savvy lol. I appreciate any suggestions.

Did you probe only Z for the new height of the tool or did you probe X,Y,Z? For tool changes you should only probe the Z value leaving X and Y unchanged.


That must be it! I definitely probed xyz after the tool change. Thank you very much. I appreciate it!!

You’re welcome. Probing X and Y establishes the center of the router hence why you need to specify the diameter of the bit you’re using. After that your other bits regardless of size all have the same center but the stick out from the router will likely change when you change the bit which is why you need to establish the Z height again from the same spot.

I have had the same problem on a project like yours. I agree probe only Z on tool changes and I have had success using using center origin instead of the left bottom corner. Also programing a final outline cut, which I see you have done, will insure the design is symmetrical.

Another question. What can i be doing wrong that dont have enough vertical space to change a tool or add the probe on a change?

Awesome. Thanks. I appreciate the advice. Im getting to a point where things are almost perfect but theres something not adding up lol

Hey Josh,

you are not doing anything wrong, the reason for the strange behaviour of the machine and how to adjust this to your needs is described here.

Awesome. Thank you very much!

Another question, If i saved all the tool paths as seperate files will the same order be follwed, such as xyz probe for my first tool path then z probe for a tool change? I hope this makes sense.

Hey Josh,

it depends on where and whether the probe commands are inserted by your CAM software.

If you have a G38.2 (Straight Probe) XYZ command in the beginning of each file, but you don’t move the workpiece between the g-code program runs, this would be pretty counterproductive. This depends on how you set this / is set in your CAD/CAM software.

The contents of the ‘tool-change’ field in the SETTINGS page (which probe only Z) is ONLY executed if a M6 (Tool Change) command is encountered in your program, otherwise not. If you split your multiple tool file into one g-code file per tool, with your CAD/CAM software you may or may not have inserted a M6 ‘tool change’ command at the beginning.

Hope I understood your question right and the answer helps you.

Thank you very much. Your response was very helpful. Now i suppose i need to find out more about my cad/cam program and experiment on some mdf.

My CAM software (Carveco) does have the M6 Tool change command but not the G38.2. Should i follow the instructions in the same order when adding those texts in bold?

Hey Josh,

yes, of course. The commands in the ‘tool-change’ field are executed by the Onefinity Controller. The g-code program that your CAM software produces just needs to have the M6 commands in it to trigger it.

I typed the code in as you instructed and it worked like a charm. I was able to perform a tool change with more than enough space. However when it came time to prob for Z my router was too high and it caused an error as the router was lowering and i suppose it did not encounter the prob. I hope this makes sense. Is there anything i can do to rectify this? Im sure it is opperator error. I appreciate all the help thus far.

Hey Josh,

yes, it’s the value after the “Z” in the line “G38.2 Z-10.0”. You can increase it to -20 or -30 or more. This means the distance it shall slowly lower Z to find the probe before it aborts, so it’s exactly what you can accomodate to your need.

By the way, I posted an updated version of everything here (with comments that explain the commands)

1 Like

Thanks. The code works perfectly. However, now i noticed whrn i home the machine upon turning it on for the day, the X, and Y are perfect but the Z is slightly off by about .0053 or so. Is there anything i can do or adjust? Hopefully this makes sense.