CNC Monitor Receiving Low Resolution Input

Not sure what is going on, but today when I started up my CNC the input resolution on my monitor (50" TCL TV) went to 480p. Typically it ran at high resolution (1080p I believe) and looked nice and sharp with no issues. Not sure what is causing this. Can’t find any settings on the TV which would be causing it, and I don’t see how to access the resolution setting on the CNC.

Anyone have any idea how to resolve this? I’m guessing it’s related to the controller output (raspberry pi) and not a monitor setting but I’m not sure how to access the settings.

Hey Rob,

Do you turn the monitor on before starting the controller?
There was a post on here about that issue if you turn the controller on first!



1 Like

Thanks. Yeah, I just found that suggestion on a similar post.

I turned off the CNC for about 30 minutes or so, then turned on the TV, waited until it said no signal (not sure this matters), then turned on my CNC and it now appears in 1080p.


Hey Rob,

in its stock configuration, the Raspberry Pi 3 that is inside the Onefinity Controller is set to auto-detect the video mode. Of course it can achieve this only if the monitor is already powered up and ready, because it requests this information from the monitor. If the monitor is not ready, the Raspberry Pi boots into a very low default video resolution (as you already found out).

However, in all situations where you don’t connect a different monitor every day, this auto-detection is not necessary. In that case it is possible to enter the resolution of your monitor in the Raspberry Pi and it will always boot to the correct resolution, even if the monitor is not on yet. This is desirable if you don’t always want to switch on the monitor first, but at the same time as the CNC controller, e.g. with the same power strip. How to do this is described here.