Dont move Z down during travel

Today as I was making my last 2 passes , as the bit flew across the table to get in the hole to begin its cut, the bit was moving down as it traveled from XY - 0 to the start of the cut.

I would really really love to see it change to NOT move the Z down while traveling to start the cut.
PLease make it so the Z doesnt move down in to cutting position until it reaches its starting point in the XY.

Yikes! I relearned last weekend to do aircuts for files that I had not run before.

1 Like

Hi Ryan - did the movement show up in the preview or simulation? Not sure if it is related to the post processor or tool paths. What software did you use to create the CAM?

I dont know… I can check in a little bit.
And for the first 3-4 cuts I definitely did air cuts. New machine, learning things. Before ruining a 30$ piece of nice maple.
All in all it turned out. I just took .1 more off the edge and sanded it.


There is the move.

To me, that shouldnt happen… How do I fix it?

That move from 0 to middle of the piece is only about 15 inches… imagine it moving all the way across the full travel?

What is your safe z set at? Set it high enough to clear any work the bit will travel over.

Alden sir… so this safe Z, will that make sure it doesnt drop below that value until it reaches its XY cutting start point? or will it just move up to the safe spot before its initial travel moves?
In this case, what if the piece was Zeroed lower left, but center was 20" away and dropping 1" in to the center to start. Even with a HIgh safe Z it would still clip… Unless my first statement is true.

1 Like

Unfortunately that isn’t a controller thing but a gcode thing… Fusion 360 shows collisions like that which I like. I don’t believe vcarve does.

So far it has worked for me. It travels to xy start at set safe z and then returns home at safe z. I set it high at 75 mm. Works for me.

Ok. let me see if I can make that happen in air :slight_smile:

would you please share with me how to set the safe z? :slight_smile: thank you

1 Like

Vcarve sure will as long as all your paths are in the same .crv file just click preview all tool paths and electrons die instead of good wood.


If you are in Vcarve you click the “material setup” area just above the different toolpaths. There are several parameters in there to adjust. The key though is to simulate all the paths together once you think you have things worked out.

1 Like

I assume this is what I need… image
So i was 3/4" above the material, and as it flew toward the starting spot, it dropped more than .8 quickly and contacted the project.
I think the problem is again, even if I set it to 2" (which I dont think i can, give my spindle, and not lots of clearance unfortunately), if it still dropped 2" on its way, it would still contact it. hmmmm

Hum? I’ve never had this behavior on the 1f or any other, looking at the photo, you may have found a situation where you need to edit the g code manually to put the cutter in a safe place before dropping?

I hope someone here is more of a Vcarve expert than I am. You might also want to check the forums over at Vectric as this looks more like a Vcarve problem than the 1f, it is just doing what it is told.

Oh I dont disagree that its a vcarve problem. I wonder if it could be hard coded to the post processor though.
The last line before the job starts (whizzes off to coord 1) to raise z to a certain number, or the alternative would be better is to eliminate whatever command comes next which is
Set Z = -.8.
What happens is the command is sent prior to the move command being sent, so as its move fast, its also dropping.
I will take a look at it, but its likely something that can be resolved with an edit to the PP.
@onefinity care to jump in?

1 Like

I am not a pro in V-carve but from what I learned if I am not mistaken the Z gap above material is when the bit (router) is moving in between cuts , so it wont it your clamps.

VCarve has a safe z option and also knows where your material is. It is designed to keep your bit safe from any collision if you set it properly. I set mine at 75mm which keeps me worry free.