Elite Woodworker Y Travel (solved. Home machine first)

I just received my Elite Woodworker which was ordered in June. I’ve assembled per the instructions. I started up the Masso Controller and went to run out the rails in the Y direction and it stops 1/2 way. Nothing is dragging on the table and I don’t see anything obvious to cause this to happen. Anyone know why?

Did you home your machine first?

Without homing the machine first, all rails will only travel half the distance.

1 Like

I had this problem as well with my Elite Foreman. I realigned the rails, checked for squareness, fishline for level,etc. No joy, all axes would stop at various points, not just halfway. I emailed the problem to OF and after a late evening epiphany, I homed the machine first. The very next day OF responded with “home the machine first”. Upon consideration I believe Masso doesn’t allow full power to the motors before homing. When I asked OF why this was so they responded “probably for safety”. The Elite is my 4th CNC machine and none of the others have this problem.

Why do you believe full power is not provided to the motors before homing, and how would this explain what you observed with the axes?

Accumulation of tolerances mean that the force to drive an axis varies slightly over the full travel. If the current limit for a given motor is set lower before homing and that value is reached, the motor would stop, presuming that’s what was programmed. This obviously is conjecture and I haven’t approached Masso for enlightenment and I probably won’t as the problem is solved. Do you have an alternate theory?

I have not considered other causes, but was more intrigued by the discussion of it being due to the motor current being modified in some way, as I have not seen this done before for this application.

The only time I have experienced such anomalies is when I have decided not to home when doing some non-critical axis moves, and the travel was limited by the current WCS (which is why homing works to eliminate that possibility).

Just so you know, the Elite owner’s manual has you try to jog the machine and THEN home it. So the instructions are in the wrong order in the owner’s manual. Very frustrating.

1 Like

Updated manual (fixing this) will be out tomorrow!

1 Like