Homing issues with Y Axis

Seems like I am only getting a valid Homing on the Y axis every 1 of 4 tries. If I hit the E Stop and home it again, it will also stop somewhere short of the front of the machine. It is not the same location each time either. I tried setting the stall current down to 0.7 and it got worse. I adjusted to 1.1 and it just did the little grindy noise it would when it isn’t homed and you hit one of the end points.

Interestingly I also just tried running the machine around with the controller and I got the little grindy noise in the middle of the cutting area and then my home for Y moved about 8 inches from the end where it was set.

Heading back out to the garage to double check set screws and connections.

Any ideas?

It may be worth checking the Y axis motor cables. See if the plug ends have a loose crimp, or a partially pushed-out pin. It sounds like the controller is losing or gaining steps on the y-axis.

Is the machine squared/trammed and on a level surface? I don’t have my machine yet, but have other less precise(cheaper made) CNC machines(3D printers), and having anything out of square, or loose bearing set screws, and any other misalignment on that axis, can cause a loss of steps, grinding, and various other issues. Just a guess based on other gear. Good luck resolving, and I can’t wait to read what the fix is.

Machine is square and parallel. Checked connections which I thought may have fixed it but it just did it again. Homed 4 times successfully though after fiddling with wires.

Interestingly with power off when I pull the gantry forward it ‘pulsates’ from smoother to stiffer. Is that normal?

Did you figure it out? I just got mine and it’s doing the same thing. :frowning:

try increasing it to 1.1, 1.2, etc if it’s stopping short.

It is better but still not perfect. Have not ran it this week. Hoping for some run time Sunday.

For me, adjusting the settings did not help. I believe it to be related to connections. Removing extensions and snuggling cables as well as tying cables down and putting on drag chains may help as it reduces cable movement. I will try it again this weekend.

No, this is not normal for unpowered steppers, it’s a sign that there are 2 wires shorting on one of the motors.

1 Like

When time permits, I would greatly appreciate you letting us know how your troubleshooting is going, and how you solve the issue in the future - which my hope is you will.

1 Like

I’ve been messing with Y-axis on this thing since Friday the 4th of Dec. with terrible results. I can’t even get it to do it wrong in the same way twice. Only had one good home and when I tried it again without changing anything it failed. I’ve had it bang into the front to only have it stop halfway the second time with no changes to the settings. OneFinity said it’s about finding the right combination of amps to volts, but I don’t know if what I’m changing is helping or hurting me because it homed differently each time I home it even if I make no changes. Very frustrating. I was really excited about this machine, but not so much right now. Got to get over this hurdle.

Support sent me this. I recommend doing this on both y rails.

3 Likes

Thank you for passing that on. I would appreciate hearing if this helps those who have had an issue with Y-axis homing.

Following this post. Curious on the outcome. I have had similar issues with the Y axis movement and yes the machine is square and level. For example, when using a joystick to move the router around, it will get stuck moving back and forth on Y axis at times. If I give it a soft push it will move again and work fine a few times then get stuck again. Initially thought it was a “squaring” issue but it is “dead” on when measured diagonally.

Is it possible to move/include this topic into the troubleshooting category? It would be great to have all the most frequently occurring issues all in one place. Also, I believe someone else (Jake?) suggested a thread listing issues and fixes. I am someone who enjoys - and has the time - to read through a variety of sources for both troubleshooting and gaining knowledge in general. However, when I get my OF and experience issues, I know I would appreciate a resource that I can go to for a clear list of ordered steps to follow to rectify the problem.

I imagine as more owners set up their CNCs, there will be a handful of common problems that need solving, much like what is happening now. If these could be organized, and their fixes summarized, I think that would really be appreciated. This would be especially true for people like myself who are new to the CNC world, who maybe lack the instinct and experience to know where to start troubleshooting, and who are also a bit anxious about their new machine not working as expected. An example is the time and effort that went into the “over/under” FAQ, which I imagine helped a lot of new owners. In the future, perhaps this might be placed in a troubleshooting section under a heading of controller software?

I realize most of the information is already within the threads, it may just benefit from further organizing and summarizing. For now, I think the attentive and hardworking people who are OF are putting all their efforts into getting great CNCs to the people who ordered them!

1 Like

Question: would it be possible to utilize a modified top part of the 3D printed connector retainer so that you could do away with the extension cable, and simply loop the motor cable back around so that the plug is on the motor end? This is something I intend on trying when I get my machine.

I do wish the wire ran across the back of the machine instead of the front… Or… Are we all backwards and the motors are the front? :slight_smile:

Can actually be set up either way, but I have to be different & want the wiring on the same end as the motors.

2 Likes

What ended up working for me was shutting down the machine, unplugging everything and then pulling the machine to the very front b/c my machine was stopping short. When i started up the 1f i homed it and it seemed to work.

My Y-axis wouldn’t home either. I’m probably the only idiot who had this scenario, but just in case, here’s what happened to me. Y axis wouldn’t home, despite trying several of the above fixes (but stopping short of re-threading the cables as shown in the video… and thankfully I didn’t go that extra step).

After turning machine off, I tried to pull the Y-axis forward, but it wouldn’t budge past about y=5. That’s when I noticed I had a block of wood jammed between the foot of the y-axis and the y-foot. (I was using the block as a clamp lever). So, stupid me. But at least I didn’t dis-assemble the whole machine!

This is how I learn … won’t make that mistake again!
Kat @ DoveTaler

2 Likes