Y-axis issues after most recent update

A little help here please
So after updating to most recent update 1.09? (I think thats the number December) I am now having to re-boot the controller because it will not home in the Y-axis, it stalls after about an inch of travel and my joy pad controller won’t allow the Y-axis to move either. When I press HOME it will raise my Z-axis, travel to the left for my X-axis then start moving forward about 1 inch or so and stop! If I grab the joy pad it can move in all axis except Y-axis. I then go to my flyout menu and press restart and once it boots up to Home it’s fine, no issues at all. I have had to do it for the last 4 times starting.

Did you save your config off or do you remember needing to ever adjust your stall homing values?

Never have had an issue with stall homing values. It’s always worked as designed before the update.
My issue with all of this is that when I updated I didn’t use the machine for quite a while because of the colder weather and just recently the weather has been good and the garage warm enough to work (above 60f ) in so I began doing a few projects this last week. That’s when it all began to act up. Had I done a project or 2 right after the update and it did this then I would be positive it would of been my issue. I may try reinstalling the update and see if that works. Any suggestions?

Having the same experience. It is a bit frustrating. I unhome my Y axis then use the controller to bring it all the way forward rehome and then it works fine. Will be looking more into it this week.

I have 2-3 times in the past year had similar after machine sitting idle for a week or two. Easy fix for me was to reclean and lightly oil the rails, boot and cancel homing, use joystick to run around the axes a few times and then no problems. I think what happens in my shop is that a week or more of idle time lets really fine dust or other contaminants settle on the rails and they get slightly “sticky”

Well that sounds like my next step after I reboot the upgrade John. I do keep my machine pretty clean however but you never know what gets screwed into the ball area. The odd thing about it though is after I restart it work every time. Thanks for your time and if it works I will give you a heads up…Bill

Yes it is frustrating but it does get to cutting once I reboot it. I will try installing the upgrade again and give the machine a thorough cleaning and lube from the outside, not wanting to tear into the ball screws yet I hope and see if it cures my issues at all. I will let you know if it worked out. Thanks for your time Tim…Bill

Hello again John,
So I took some of your advice and mixed it with Tim and BJ’s suggestions and Think it fixed my issue with my Y-axis not homing as it use to.
I thoroughly cleaned all the rails along with oiling the ball screws by removing the oil cap bolts, manually reset my home positions in X and Y axis after I had run the machine around with the joy pad and so far it seems to have worked out. Now it was all done in the same day and it hasn’t been shut down to reboot after a few days but I did shut it down then go in and eat some lunch to come out again to do a restart and everything seemed to work perfectly as it use to. I never did try to re install the upgrade 1.0.9 hoping it was more mechanical than hardware. So Thank you all for suggesting those possible issues because I’m up and running again (I think) …Bill


Glad you are back in business. I think you will find that it isn’t necessary to do a full lube job just because things have been dormant for a week or two. Just delaying the homing until after you move the router around on x and y should be sufficient. You don’t have to cancel the message for initiating homing, by the way - as soon as the steppers are energized, they’ll respond to the joypad.

I don’t think it is really that things are “stuck” - I think that default settings for the current draw for stall homing is set pretty close to “at-rest-inertia” if that is a term, and a teeny tiny bit of resistance for any reason at all at start up can trigger stall homing. The controller doesn’t act on the stall homing during a cut, when bit resistance is often much greater than the stall homing settings.

Although one could play with the stall homing power requirements, keeping it close is very safe; I’d rather just jog around a bit first. In fact, my practice is to leave the spindle wherever it finishes and power down for the night. When I start up again in the morning, I just joypad jog to within a couple of inches of X and Y 0 before initiating the homing.

1 Like

I know you posted this a long time ago, hopefully you’re sorted.
If not, take a look at this link:

This helped me a lot.

Bill Butler

Thank you for commenting on the subject bill b. I have not had any issues since way back in January.
I’m still not really sure if it was the cold weather at the time or just a strange occurrence of some sort but things have been good ever since. I will keep your suggestion on the back burner for any sign of the issue coming back though.
Once again thank you for your care in our Forum, it’s one of the main reasons along with the quality of this machine I chose ONEFINITY.