Everything works until I hit Play - then nothing

this morning I started a project to pocket some aluminum. It was going great, but I decided to stop the job because I wanted to install the Z-20 and start over since it was sitting on the bench.

After installing, setting up, and re-zeroing I restarted the same job from this morning.

Two things happened;1) I forgot to turn on my spindle (I forgot I turned it off), & 2) the spindle moved to the workpiece and plunged the bit hard into the workpiece as if the zero wasn’t set.

I hit stop right away.

After reviewing everything and turning on the spindle power, I went to start it again. Everything work right up to the point where I hit play…and then nothing. Absolutely nothing happens - no movement, no spindle start - nothing.

I’ve been trying things all day with no luck.

  1. I reflashed the controller SD card
  2. I re-posted the G-code
  3. I re-installed the post processor
  4. I stopped it twice in a row (saw that somewhere)

I am at a loss and really need to get this job done and the finished pieces to the anodized.

Anyone have a clue what more I can do?

Anything in the messages section of the controller that can help understand the issue?

Thanks for responding Andy -

I don’t know why, but it actually ran as it should soon after my post. However, I had to stop the job again to make an adjustment and now it’s F*#$&%d again - acting just like it did when I first posted…or not acting at all as is the case.

I tried again and got this in messages:

And here is the beginning of my G-Code:

I’m a worried there something big wrong with my controller. It’s doesn’t seem to fully shut down from the menu - the touchscreen freezes on this:

And there are times when I power on the controller and it starts to simulate the code, but freezes on the simulation notice box with no progress showing.

This is crazy frustrating. I’ve waisted all day on this and am absolutely nowhere when I have too much on my plate to get done in the next few days. Now I’m a freaking day behind.

Here’s the simulation dialog box I get…and nothing happens from here - it’s just frozen:

I just tried a new toolpath using a different bit and still have the same problem - same warning just different tool number for the warning. AAAAHHHHHHHH

The missing tool number warning is not an issue, the controller doesn’t use a tool table. I would recheck the connections to the Z stepper motor since you changed that.

Also note the “Probe Z” box is lit up green indicating the touch plate and magnet are currently completing the circuit - if this is not the case there might be something electrical going on.

May be a bit of a random but i sometimes find the controller screen doesnt behave / refresh, so I sometimes access the controller over the network via a pc and all works well or if possible i refresh the controllers screen. But these situations are random yours seem more consistent.

Another, with respect to touch probe, i had trouble with a different machine when the magnet was touching the touch probe when stored.

Hey David,

This is this issue (CNC Controller reboots despite being powered off because is backfed by the power from the monitor through the USB port, but cannot complete a boot with that low power):

This is known to happen on buggy firmware. What firmware version are you using?

1 Like

I read about the back feed so now I keep the touchscreen on, but with no usb. I have a laptop connected and use the web interface. The WiFi kept dropping so I grabbed an old network switch so both the controller and the laptop are hardwired.

When I reflashed the SD card a loaded 1.2.1 firmware (I think that’s the number - it is the latest current version whatever the number).

I had my problem before reflashing the SD card and nothing changed afterwards.

Re probing - it probes fine. In fact everything works as it should until I hit the play button. I didn’t catch the probe button being green - but I’ll keep an eye on that.

I’ll go thru the wire connections today. I have had several bad connections in the molex plugs in the past.

However - I also have my spindle controlled by the g-code/controller, and it doesn’t start when hitting play, but will start with a manual M3 command.

Hey David,

Many people in this forum stick with 1.0.9 firmware as it’s known to be very stable.


Ok - I will reflash to the previous firmware…and hold my breath.

I have had that issue where it doesn’t load the correct new file. I end up always loading it twice to make sure.


One more question though - will the Z-20 work with the old firmware?

Hey David,

oh sorry, I did not think of that, 1.0.9 will not offer the simple Z-16/Z-20 choice in the default settings. It will however support the Z-20 assembly correctly if you set

  • travel-per-rev” to “10
  • min-soft-limit” to “-160”, and
  • max-velocity” to “7

of motor 3 on its MOTOR page. This is what the “Pick your Z Slider Type” choice sets on later versions when choosing “Z-20 Heavy Duty”.

Alternatively you could try firmware 1.3.0 Alpha 2, but it’s in alpha state.

1 Like

I installed 1.3.0 and successfully ran a toolpath. However, I went to run a second tool path and I am back to the paperweight.

Three things I’ve noticed:

  1. The controller software keeps reverting back to automatically update to the latest software - so I was back to 1.2.1 after a reboot. Even when I uncheck the box, it defaults back to a checked auto-update box.

  2. I am using the fusion post processor - On startup the machine will home as it should - then I set zero on my 5"x8" workpiece in the middlish front of the waistboard. So far so good. When I load my file, I get “over” on my toolpath. The graphic makes it appear as though my workpiece is the same size as the entire waist board and I moved zero making the workpiece too large. The workpiece in fusion is 5x8.

  3. lastly - it now goes to the rear right corner after completing a job…while I like this, could this be what’s causing some of the issue?

Hey David,

really? Are you sure? Are you saying the controller now updates itself without your interaction?

Usually I suggest to uncheck this setting on the ADMIN page:

and then reload the CONTROL page.

I am not sure if I understand. You have to make sure two things: 1. That the workpiece zero in your 3D model is zeroed at the same point in your real machine’s workspace, and 2. that your 3D model is not bigger than the maximum workarea (816 x 816 mm for Woodworker model, 1220 mm x 816 mm for Journeyman). See here for explanation.

I don’t know why it goes to the right rear corner, but I would think it is because your g-code program tells it to do so.

1 Like