Files not loading

I am tearing my hair out trying to solve a file loading problem. I have four toolpaths saved on my usb drive and they all show up on my controller when I plug it in. However, when I added two more toolpaths that I wanted to run before the other four, they are not showing up on the controller. Yet they are showing on the usb drive while in my computer where I saved them. I have recalculated these two toolpaths many times trying to get them to work but they keep showing up blank when put into the controller. It makes no sense to me why this is happening. The files show up on the usb drive but don’t show up on the controller to run them. They are standard Vetric NGC files just like the others that do show up.

Well, I found a fix for my problem. In VCarvepro there are 3 options for saving toolpaths. The first two did not work but the third one did. Visible toolpaths to multiple files finally worked. Still baffled over this.

1 Like

That is strange, but thanks for sharing your fix. I’m sure you’re not alone in this problem!

Turns out I have discovered that the real problem is you can’t put a decimal point in the name of the toolpath which I wanted to do to let me know which tool I intend to use. I would put .250 em for a 1/4 inch end mill. Now I just leave out the decimal point and it works perfectly.

4 Likes

Awesome to know! Thanks for sharing

You can put in a decimal, but you have to have a space right after the decimal. For example . 250 instead of .250

1 Like

Son of a gun. Who knew? Thanks for sharing that!

Interesting. Maybe this is what was happening to me yesterday that had me extremely pissed off as I ran a file off my usb on Sunday and it worked fine. I wish I remembered how I saved those files to the usb drive on Sunday when it worked.

Hey this dumb and dumbest
I have downloaded some very simple vector files. Etsy. I opened the file in Vcarve pro. Went thru the material sizing, did material setup, toolpath operations hit calculate. Got no vectors warning. Assigned vector and recalculate. Then hit save in file colum. Moved down to send to and sent vectors to flash drive. Removed flash drive per properly. Went to machine. Booted system, plug in USB port. Opened files. Got nothing. Went to second computer I have Vcarve on. It reads the flash drive and opens it up in Vcarve. Any thoughts.
Tech support does not respond the office does not answer. Guess they celebrate New Years longer then we do

Hey Tom,

welcome.

In order to show up on “Open files…”

  1. your files have to be of supported format (.nc, .ngc, .gcode, .gc). Which format did you save?
  2. your Flash Drive needs to be formatted with FAT32, NTFS or ext2/ext3/ext4. Nowadays devices larger than 32 GB are usually formatted with exFAT filesystem by default.

Thx for your response. So how do I reformat my flash drive or do I need to purchase a new one properly formatted

I’ve reformatted the flash drive. Then reload the flash drive. Drag and drop. No luck. So I’ll go back and figure out what format I saved in. Thx. For your help

If that’s true then you saved the VCarve drawing file (CRV) and not the toolpath files (NGC).

After you calculate all of the toolpaths you have to save them separately. Over in the right side Toolpath fly out there is a little disk icon just above the toolpath names. Click that to save your toolpaths as .NGC files.

2 Likes

Can not find the ufo disc. I’m using Vcarve pro ver 11 perhaps we are on different versions. Also can not find any video of NGC FORMATT. DFX seems to be all the rave. Any other thoughts

Did you verify that the files you put on the USB drive were .NGC files? Those are the ones the Save Toolpath command on VCarve will create if you are using the Onfinity Post-processor. I am running VCarve Pro Ver 11 and am doing everyday what you’re trying to do.

If they were NGC files then you may have an issue with the USB formatting (as @Aiph5u suggested). You’d format it by opening File Explorer in Windows and then right-clicking on the USB drive. There you’ll find an option to format it as well as a dropdown box to select a formatting type (select FAT32 or NTFS).

But, I still think you saved the drawing file (.CRV) and not the toolpaths (.NGC) since you were able to open it in VCarve. VCarve won’t open the toolpath files, they’re text files of simple GCode commands.

DFX has nothing to do with any of this. It is a drawing file standard and a very old one at that. It’s the lowest-common-denominator format for drawing programs like Autocad, Inkscape, Corel, etc. It’s a garbage file format. Modern apps use formats like SVG.

1 Like

Thank You for this post I was pulling my hair out.

You are welcome. It seems to be a post that keeps on giving.