Firmware Update 1.0.7 BETA (3/11/2021) (Outdated Firmware)

From the release notes:

“New probe diameter in probe dimension field. This will allow you to set a default probe dimension and be remembered upon reboot.”

How to downgrade from 1.0.7 Beta to 1.0.5:

2 Likes

Just an FYI that I upgraded to 1.0.7 BETA on Saturday from the 1.0.5 firmware my 1F came with about 3 weeks ago. I was finally comfortable with the machine and pressing to get a gift project done, the Vertic Heart-Shaped Box, after a few small cam clamp tests.

After a bit and loading the new box file I lost my X-axis on the screen and it just showed Y and Z. This was not fixed with a shutdown or a restart. I also had an unusual controller issue when I would try to push the spindle straight back in the Y axis the Z would rise and it would travel an equal distance in the X so an up and diagonal to the right movement of all axies. When I tried to pull the Y forward the inverse happened and the Z came down, the X ro the left, as the Y came forward.

At that point, I checked all cables and connections thinking something may have come loose but did not find anything and I did not have time to mess around so I reverted back to the v1.0.5 and things worked as expected.

I do not know if there are any logs or files from that which may help and apologize for not contacting support to try and diagnose the issue but I can try to recreate the issue if needed with the same file paths I used on that box project if it can help.

I just upgraded to the v1.0.7 BETA again and will be doing some more simple things the next few days and will report any issues. Please feel free to reach out if I can be of any assistance.

That is solved by a simple reset of the configuration.

I just upgraded to firmware 1.0.7 beta version from 1.0.5. When I probe the XYZ, it is wrong on all 3 axis. The x and y are off by 1/2 of the probe diameter, and the z is .019 too deep. I am using imperial dimensions. I measured my probe(purchased with machine), and found the “probe-zdim that is preset to15.4mm (0.6063) is actually 14.9225mm (0.5875”). Exactly the error on my Z depth. The “probe-xdim” and “probe-ydim” are set to 53.975mm (2.125") they are correct on my probe. I tried to set probe diameter to 0.000" instead of the 0.250" default size, re-ran probing and got the same location as previous attempt. Anyone else have this issue? Anyone figured out a fix? I just did a spoilboard grid pattern last night, and now nothing aligns when i re-ran program to “test” firmware update.

Update. I added 3.175mm to “probe-x and y dims” and it now locates on the corner with centerline of 0.25" dia. probe. I changed the zdim to what my touch probe actual measurement is, and the z height is correct.
Something else I am seeing, when i re-start the controller, is that the units are imperial, but the jog/step increments are still metric.numbers. Buttons from left to right on the control screen show, 0.1,1.0,10, & 100. If I use the 10 button the axis moves 0.500". I tried doing a configuration reset, but all that did was change all my touch probe settings back to system defaults

The beta has a bug when you use inches in the control page for probing xyz it will be off. If it is set to metric it will be correct. The final version of 1.0.7 will have this fixed. So, for now, always use metric for the control page.

2 Likes

Super dumb question here. It’s asking for a password when I try to update it. Is there a generic one or did I set one up at some point?

For most of us, the password is onefinity. If you have one of the very early machines, it’s buildbotics.

That said, the official 1.0.7 firmware was released today, so no need to install the beta.

1 Like

My was onefinity, thanx!

onefinity, is there a way to delete just certain files from the dropdown list on our controllers? Had a file upload then did the update and then the file kept giving me errors and staying on the Preparing popup until I E-Stopped it. Just renamed the file and reloaded it from my desktop and seems to be working now.

Yes, just select the file you want and hit the trash can button. You either choose single file or all files on the drive

Each time I try that my file jams the system and it stays on the Simulating pop-up and doesn’t count up or go away. I have to E-Stop it to get it to go away.

If you still have a copy of the bad file, send it to support@onefinitycnc.com

Here are the files that were referenced

DallasCowboys2Logos24x24x0.5[3-16].crv (185 KB)

DallasCowboys2Logos24x24x0.5[3-16].ngc (26.9 KB)

DallasCowboys2Logos24x24x0.5[3-16].ngc (26.9 KB)

Well I downloaded the 1.0.7 beta version and lemme tell ya - sooo many improvements. Seems more accurate/precise. Snappier and the GUI is much improved. No issues with my XYZ probing - on point every time - had alot to do with @charleyntexas hookin me up with that snazzy avg chart from my xyz readings… but all-in-all my first engrave, chamfer, and cut was flawless. Oh - and the added safety feature to touch the touch plate to the bit is prolly my most favorite feature… I’ve ruined 3 bit bits forgetting to connect the magnet. Keep up the awesome work @onefinitycnc! thank you!

4 Likes