Firmware Update 1.0.8 (5/5/2021) (Outdated Firmware)

Beauty test Tuvix :+1:. I just updated to 1.0.8 and will be testing lower max. dev. values as well. I tried lowering the value while in 1.0.7 and didn’t notice any difference. The radius I will be testing is .25".

The radius on the test cuts was 2" (4" diameter"). I’m doing more tests today on more complex ARCs on all axis.

Should we start a dedicated thread dealing with ARCs and the settings we find that deliver the best results? It’s a limitation of the Buildbotics controller so we will likely be dealing with this for some time unless Buildbotics has this in their development roadmap.


I vote for a new thread. Just be sure to and a link here for everyone.

1 Like

Here you go, hopefully I put it in the right place!


Sweet :+1: Thanks @Tuvix72 and see ya over there

1 Like

I selected the bbctrl-1.0.8, and nothing happens, do you need to open something else

I apologize for not responding sooner. It was a while ago but I believe the steps were:

Do all these steps on the touch screen, not from a computer

Insert the usb into one of the usb slots

Click the upper left corner icon to get to the settings/close choices

Choose network under Admin

Click the box above wi fi and choose disable

Click general under Admin

Click on update from file (this button is in 1.0.8, I think it existed in 1.0.5)

The open file box should open and you should see the update file (or at least see the usb drive which you can open)

Select the file and click open or double click the file( sometimes when I’m loading a file only double clicking works)

To the best of my recollection that’s what I did to get the update started.

Do yourself a favor and attach a mouse, corded or wireless, to the controller. My Logitech wireless one did not need anything to start working. It makes selecting things on the screen so much easier than using your finger on the touch screen. Don’t forget to turn the wi fi back on when the update is done( if you use it)

Please let me know if this helps.


I open the bbctrl-1.0.8, and the only choices are scripts or src, neither one makes sense, maybe I’m not downloading the files correctly

Have a look at the first post of this tread ,you will have your answer

How To Install:
Updating via USB
You’ll do an update via USB using the following steps:
Copy the blue .bz2 file below onto a usb stick (it must be formatted as fat 32 or ntsf). Click the flyout menu (three bars on top left), general, under firmware click ‘UPLOAD’. Select the 1.0.8 file. Depending on your shipping date, the password to update will either be buildbotics or onefinity

I hope it will help you

although its for 1.0.4, same steps apply: Onefinity Firmware Update 1 0 4 - YouTube

This is the file you should be installing. Put it on a usb and plug it into your machine. Don’t try to open it like a program file. Use the General tab under Admin on the flyout menu. ( I can send a picture but it will have to be later).Sorry I should have checked out the file before answering. Good Luck

onefinity-1.0.8.tar.bz2 (2.15 MB)

@onefinitycnc is there a plan to release an updated firmware soon? Just wondering what the time line on a fix for some of the known bugs are coming. I fixed the imperial/metric switching thing by changing the code myself but I know others find this annoying among other issues.

1 Like

@onefinitycnc FYI - I finally installed the 1.0.8 firmware update last night. I still had the lost step issue with the Fusion 360 2D Pocket operation. My units are all set to Inches / Imperial. I tried switching all the units to metric, but that didn’t help.

I ended up switching to 2D Adaptive Clearing and was able to successfully finish what I was doing.

I’ve attached the g-code in case it helps diagnose and fix the firmware.

01 - Washer (32.0 KB)

Which post processor and setting are you using in F360. From line 40,I see a lot of G1 X Y and I was expecting G3. Ensure you have ‘useCircularInterpolation’ enable. Here is the post processor I use.

Here’s a screen grab of the currently installed post processor. It appears to be the same version as what’s on Github. Circular interpretation is enabled.

For whatever reason, I’m unable to install the machine file.

Weird that you have an error on the machine library. Just try again by first loading the post processor.

Note also that It look like you dont have the same processor. In your image I dont see same info (red square) specific to my version. Meaning custom proprety, not value)

I just noticed there was a bell next to the post processor I already had installed, apparently indicating a newer version was available. I updated it.

The version number is 43467 on my (now) updated version vs 43409 on the Community Edition processor (which I was able to successfully install so now I have both available).

Which version are we supposed to be using?

Autodesk update theirs from time to time. I update my community version yesterday and 43467 was not there. I’ll look at the change.

Anterior autodesk version did not work for me (same problem you have) and started using the community version and the 1.0.8 firmware.

Note, I suggest you reset your 1F config [ADMIN, Configuration, Reset] and also reload your gcode on 1F before trying again. Hope this will work for you

The link I provided is a custom version I updated. I added few custom properties (Spindle Delay, Spindle Pause and Circular Interpolation)

1 Like

I reset the controller, added the machine config, am using your Community processor, circular interpolation is enabled, re-exported my gcode, deleted all gcode from the controller and reloaded the file, but I’m still getting lost steps / stuttering. :frowning:

I also used the most recent version of the processor that F360 updated to this morning (43467). Same issue. It just doesn’t like the 2D Pocket operation.

Here is the most recent version of my gcode file.

01 - Washer (32.1 KB)

And here’s a F360 link to the project file if anyone wants to laugh at my pathetic modeling skills to see what’s causing the problem. “01 Washer Recess” is the operation that’s causing problems.

Can you try ajusting the Smoothing Deviation from 0.004in to 0.0004in in your ‘Passes’ tab of your 2D Pocket?