Firmware Update 1.0.8 (5/5/2021) (Outdated Firmware)

Downloaded it. Having problems with 1F recognizing files in USB. No answer yet.

Can you plug in a ethernet cable? I think it will then automatically update if I remember correctly…

Yes. I am going to try my Extender which has plugins. But I’m on 5G/2.4g so it might not recognize the 2.4g.

I’m also having problems with 1F recognizing files off of USB. The first thing I did after assembling it in the house yesterday (air conditioning) was hook up an ethernet cord. I was prompted to update to 1.0.8…I kind of regret doing that now. My phone gets wifi signal out in my workshop, but my 1F does not.

I troubleshot that it shows the USB in Filesystem/Media/<yourUSB’sname> (as opposed to in the upper L corner under ‘Recent’, ‘Home’, ‘Desktop’ as shown in the manual).

The USB shows up in that /Media folder, but it shows nothing in it (even though I have an .ngc file saved there as confirmed on both a macOS and a Win10 machine). It also does not show an eject icon (go figure, how do you eject a folder buried in its hierarchy?).

I have yet to bring my laptop out and try the “Access Point” with my Win10 machine running Vectric Aspire. I’ll try that next.

After that, my only other solution is to go buy a cat6 100 foot ethernet cord and string it on out to the shop (attached garage).

(In seemingly unrelated news…I selected imperial from metric, but the increments did not change {0.1, 1.0, 10, 100}. I hit 100 Z down {not thinking about the change from metric to imperial, and I knew 100 mm was a good jog down in prep for zero}. The machine obediently tried to drive the Makita and its Whiteside v-groove bit through the table. I now have a nice gouge in the aluminum rail at 0,0.

I later told my wife the rather silly thing I did so she could learn from my mistake. I showed her the button on the touchscreen, brought it to metric and back to imperial…lo and behold, the increments changed to 0.005, 0.05, 0.5, and 1.0. Hitting 1.0 and a - or + causes the machine to obediently move 1.0 inch.

All this is to say that 1.0.8 may have some decent bugs in it.

For the record, we got our machine in early May, but…life happens and we just now put it together–thus the upgrade and lack of any experience with the 1F.)

Support emailed me back (less than 24 hrs!–Great job 1F!!)

Somehow missed this: File Format For Loading Files onto a USB stick

If above is TL;DR: Your USB must be formatted to NTSF or FAT32.

In their email, support recommended sticks between 16-32GB.

Modern one I was trying to use was 512GB…found an old one that was 1GB and it worked fine once I formatted it for FAT32 and loaded the file onto it (to then load on to the 1F controller).

As far as 1.0.8 being buggy, I’ve found that if you have imperial selected as your default, it still loads the metric increment buttons at the bottom (0.1, 1.0, 10, 100). The workaround is to select metric, then select imperial again (which then forces the 0.005, 0.05, 0.5, and 1.0 to load as the four increment buttons at the bottom).

Maybe it’s unfair of me to criticize the above as a bug for 1.0.8…maybe it’s been that way for longer.


I have same issue with the buttons being in metric even thought it starts as imperial. I can also confirm the workaround you mentioned works for me as well. Just need to remember to do it every time I turn machine on.

Newbie question…sorry if I missed this somewhere but does the new 1.08 firmware support G2+G3 g-code. I am pretty sure I read that the new firmware will only run G1(line moves) which will make programs much larger. Has anyone found a work around on this so they can run G2+G3? I am familiar with reading and writing G-code and this would limit me quiet a bit. Also, where can I find a list of G-code that the controller can read?

Seems to be supported:

My files have many G2/G3 in them and they all work.

1 Like

I was back and forth with 1F support and their controller does not support true G2/G3 arc movements. I know this is confusing and disappointing as all of the links and info land us at the linux cnc doc. Just a lazy redirect toward accurate info overall but irrelevant info to our specific controller. The arc movements are segmented into line movements.

Arc moves shouldn’t be that complicated. Did Onefinity explain why they cut this out?

@Techrise No not in any sort of detail. Talking to 1F support is like pulling teeth in my experience. The only thing they added was to update to 1.0.8 (I am still running 1.0.7) as they have made some changes to try and decrease the faceting/stepping around corners. I have increased my microsteps in the controller to try and increase the resolution to combat this. I found the machine runs much smoother and the finish quality even on roughing passes is greatly increased but the stepping around corners is still there, plain as day. In wood, completely unnoticeable. In aluminum, sticks out like a sore thumb. This is why I decided to omit the controller when I ordered my Journeyman model. I am going to upgrade to the centroid acorn and a set of digital closed loop stepper motors for my machinist model and use this 1F controller on the Journeyman.


Thank you @alldaysammyj . I will eventually be cutting aluminum with the Onefinity and might have start looking at better controllers to get a decent finish. Hopefully Onefinity can fix this issue though too.

@WaywardWoodworker I am interested in what program you use to create files and code. Are you running the new 1.08 firmware?

I use Fusion 360 and cut aluminum all the time and the curves are spot on. The controller might be interpreting the G2/G3 commands into line segments in what it sends to the stepper motors. I can’t speak to that level of detail - the G2/G3commands are in the g-code files and the Onefinity plows out what I designed like magic. For what I do you can not tell if it creating line segments or not. I’ve found the machining strategy/speeds and feeds/proper cutters etc. made the most improvement in the finish on aluminum for me.

I am running 1.0.8, when I received my Onefinity last month it had 1.0.7 on it even though 1.0.8 was available, the first time I booted it up I was notified there was an update and applied it. Never ran it on 1.0.7.


@WaywardWoodworker do you have any pictures of the aluminum milling around corner segments for comparison? This is the faceting/stepping I’m referring too. If 1.0.8 is all that much better I will consider installing it.


I’ve not cut anything with a radius less than about 2 inches, I didn’t notice anything like your picture but I can’t say it wasn’t there. Next time I cut a part I’ll take a closer look at it.

1 Like

I was doing my first job on aluminum. Making a circular plug. I had the same faceted circle.


Nice plug none the less, good job. Is that an end cap for the 1F? Also gotta ask, are you running 1.0.8 firmware?

@alldaysammyj. Yes it’s a cap for 1F. Diameter is a little big so need to make one slightly smaller. Yes I am running 1.0.8.

I’m also trying to figure out the settings to combat the lack of support for arcs. So far I’ve gotten pretty good results reducing Max-Deviation, however on freeform objects when it’s converting arcs on all axis, the results are still poor.