Firmware Update 1.2 Beta (12/5/22) (Outdated Firmware)

Updated 1/31/23

This release helps us collect data and ensure there are as few bugs as possible.

Read below before getting to the download button at the bottom:

A little background.

Firmware 1.0.9 was the longest running firmware we’ve had up since release. It was solid, relatively bug free and very stable. We worked hard on 1.1.0-1.1.1 to add many new features and build on future additions to the firmware. We did private beta testing and in house, everything worked great. We gave it to a hand full of testers and, they too, had almost no issues. For some reason we skipped open beta testing to anyone who wanted to try and released it to the public. Unfortunately, with the larger sample size more bugs were found and with the many major changes it became harder to squash the bugs. We made some human errors and rushed out what we though was ready to go in excitement of getting these features out to everyone.

After a few weeks it became apparent that 1.1.0 and 1.1.1 had enough bugs we couldn’t recommend installing it and resumed installing 1.0.9 from the factory. Unfortunately, we couldn’t ‘turn off’ the ‘update available 1.1.1’ when you connect your controller to the internet as some users are already on 1.1.1 and we’re unsure if it would break their machine or stop their ability to auto update forever, so we left it up.

What are we achieving with 1.2 firmware?

Todays firmware release may seem like we’ve moved backwards, but allows us to do two things;

1.) We went back to the fresh and stable release of 1.0.9 and added 4 of the biggest bug fixes that can affect your carves (listed below) but also will not introduce any new bugs. This means that 1.2 will not include all the enhancements that 1.1.0 -1.1.2 alpha included. This is to ensure you have the most stable firmware you can possibly have on your machine and avoid any unforeseen issues bugs may cause.

2.) This also allows us to essentially ‘skip’ 1.1.0 and 1.1.1 upgrade notifications users would have when connecting their controller to the internet and now it will show the 1.2 update bypassing the buggy 1.1 releases.

What are the changes from 1.0.9 to 1.2 firmware?

  • (bug) Fixed bug when uploading files with special character or spaces in the file name (like . _ ?*&^&, etc.).

  • (bug) Max usable file size increased from 100mb to 1gb.

  • (bug) Fixed long/slow movement bug (mostly seen in laser movements that would case the machine to skip steps with long movements under 15 ipms).

  • (bug) Display can now be rotated 180 degrees.

  • (bug) Fixed and issue when the most resent file uploaded wasn’t automatically made the active file.

  • (Visual) Added a visual change of the logo header and IP address/ssid/firmware version in the header and new probe visuals.

  • (Visual) New Wifi menu that shows available networks instead of having to manually adding it.

  • Added new ‘reset configuration’ values for z-16 and z-20 Z sliders.


If you are already on 1.1.1 or the 1.1.2 alpha, we recommend doing a full ‘reflash’ of the os to 1.2.
If you are on 1.0.9 and below, you are free to upgrade via the traditional usb upgrade via the general page on the controller.

Upgrade file for those on 1.0.9 and below:
bbctrl-v.1.2.1_RC3.tar.bz2 (2.7 MB)

Full SD reflash for those who have ever installed 1.1.0, 1.1.1 or 1.1.2 alpha:

How to reflash the sd card: How to reflash the operating system on the Onefinity (Full SD card image)


I would like to note that this version does NOT include the “PwnCNC VFD” listed in the tools menu. If you have a PwnCNC spindle kit, and really want to upgrade to 1.2, please reach out to us at and we can assist.
Installing our VFD is definitely doable with the 1.0.9/1.2 versions but it is a bit complicated.


Does 1.2 move swap to memory from SD like 1.1 did?


With 1.0.9 (and even 1.1.0 or 1.1.1), whenever I would upload a gcode file through the network, it would process the file immediately after uploading, which would give me an indication that the file successfully uploaded and was ready.

Now with 1.2, whenever I upload a file, nothing happens (no indication that the file uploaded successfully or was processed). If I then go to the file dropdown, I see my recently uploaded file somewhere in there. Only if I select it, it then starts to process it.

Is that the intended behavior with 1.2?

1 Like

1.2 works exactly the same as 1.0.9 did.
only 1.1.X shows file upload progress.

how do you get the screen rotate to work?

1 Like

Build updated.


  • Added new ‘reset configuration’ values for z-16 and z-20 Z sliders.

Did a full reflash and it works well for me

1 Like

how do you download either file to a USB? The .xz file is not reconized by the Onefinity software, And cant get the other to download at all>

Both 7-Zip and WINRAR will open a .xz archive.

1 Like

OMG - Im still trying to figure out how to go back to the old version that worked. Surprised they even released 1.1 with the volume of issues. Has anyone had a fire with 1.2 yet?

I reflashed the SD Card to 1.2, and I’m having issues with selecting a file. When I select the file, it does not actually load it. I have to go the dropdown of recent files and select it there before I am able to run the program.


Yeah, I randomly have the same issue.

1 Like

That’s the same behavior as 1.0.9 and previous.

If not, please post some video (along with the gcode files) so we can take a look.

Yes, you can often find the file in the dropdown list but that gets awfully long and sometimes it’s hard to remember which exact file naming you used and if you are going through several iterations of the same carve, it’s a bitch to find. Instead, I typically just reload it again (or again and again) until it comes up.

And then… It often loads without the 3D preview which I find is a great sanity check. So, I’ll upload it yet again until it does. I’d love to see this fixed in some update.

I’ve taken to including the date in the filename. That at least lets you narrow down the list. E.g. “23-01-15 House sign”


I have never had this issue in 1.0.9. I also reverted back to 1.09, and again do not have the issue. I’m creating G-Code with VCarve Pro, and it happens with all files on 1.2. - Here is a video on 1.2 before I reverted back. Apologies for some parts that are out of focus, hope it gets you what is needed.

Summary: I have never had this issue on 1.0.9. The issue began when updating to 1.2, and the issue completely went away after reverting back to 1.0.9.

1 Like

I thank goodness never ever upgraded to anything beyond 1.09 but i do rather frequently have a problen with selectin any file that i have to scroll down to. to get around this i frequently put an a or a b in front of the file name so it is on top cause sometimes it simply will not scroll down. at first i tried reloading it several times and that worked once in a while, I do not know if it is the controller’s / firmware problem or my non onefinity monitor. but it is not bad enough to make me change anything

1 Like

What we expect to be the final version of 1.2 has just been uploaded. ( upgrade package file). If no bugs are found, we expect to release 1.2 to the world as the latest firmware this week.


Does this latest beta update for v1.2 firmware include the the VFD config selection for the PwnCNC spindles?