Getting Homing error after installing the CNC for the first time

I just finished installing my Foreman Elite CNC and turned on the MASSO, the EStop and Homming button where flashing, so I disengaged the EStop so that went away and tapped twice on the homming button (Since it was flashing , saying double tap to home)
first Z axis went all the way up and after that I got a homing error.
I have tried turning it on and off and trying again and get the same error.
I read on another post that unplugging and moving the axis by hand might help, did that and that didnt help either.
I have not changed anything in F1 Tab (In fact I dont know the password yet HTG didnt work)
I can see that in the F1 tab X-Home senso and Z-Home sensors are high (and its my understanding that , that is showing the problem)
But not sure what the problem is with the sensor and how to fix it.
I am going to attach a video where it shows when I try homing, the spindle goes up all the way on the Z axis and then it starts going to the right on the X axis, very shortly after moving couple of inches maybe I get the homing error, If I double tap on the homing error It will move a bit more to the right and It will error again.

On a separate but maybe related subject, I hear a humming noise from the Z Motor, when I hit the emergency Stop the homing noise goes away and when disengaged it comes back, Is it suppose to do this? Im worried If Im doing something wrong and I’m damaging the motor.
I will attach the screenshot from the F1 tab as well.

I tried to read here: https://docs.masso.com.au/
and watch the youtube videos here: https://www.youtube.com/@MassoCNCAustralia
To learn how to work with the MASSO G3 but since they are not exactly one to one (one is the touchscreen for onefinity and the documentation is more general masso) its hard to find what you are looking for , I will there were better tutorials/documentations out there to help.


@moosaes

Peter (CNCNUTZ on Youtube) has a great video about setting up homing on the MASSO G3 Touch…I recommend you watch that. He does a GREAT job and is very knowledgeable.

Jay

1 Like

Hey Moosa,

yes, this is the holding current. This holds the stepper motor in its current position.

Thank you @MstrODstr I watched it quickly one but I will watch it again!

@Aiph5u that make sense, I wonder why when the EStop is engaged the homing stops, wouldn’t it still need to keep the spindle in place?

So far I have figure out that the X-axis sensor light is not red, Im assuming when they are in low position meaning they are not in contact with metal the red light should be on and in F1 tab it would show as low.
My X-axis sensor light is off and it shows high in F1 tab even though there is no metal touching it, so I either need to reset it somehow or the sensor is broken.

I think my x-axis sensor is bad, one time I turn the machine on and its low and it works, the next time i turn it on its on high (the redlight is off the whole time) and it wont work, it keeps flipping back and forth randomly between the two state.
I think I should contact them to get a replacement for it.

More likely a bad wire connection. Try swapping it with another axis.

Any luck ? W e both seem to have the same problem to a T. I have checked all wiring and flipped sensors around with no luck. Please let me know if you find anything. Also that hum is weird and I don’t have it on my other cnc which also runs on the g3 from MASSO.

mine was a faulty sensor for the x-axis, contacted them and they shipped me a new one.
the hum seems to be what keeps the z-axis in place (thanks @Aiph5u for the explanation).
I looked closely and saw when i hit the EStop, the motor does go down (the stepper motor no longer keeps it in place)

I just setup my Onefinity Elite Foreman and I’m having almost the exact same problem. During homing the x-axis will move an inch to the right and then throw a homing error. I changed the sequence around and the z and y axis home just fine, but not the x-axis. I swapped homing sensors around and the problem didn’t follow. I changed the motors around and still the problem didn’t follow. I checked wiring connections and reseated them to no joy. I’m lost as to what to do next.

I have the same problem. Any new answers?