Help! Losing “Home” during carves

I’m starting to think that this is related to the ball nuts. The Y axis seems loud to begin with but having no frame of reference, I moved on.

Today while trying to troubleshoot and watching the way everything moved while it locked up I thought I could see one side move slightly more than the other. While investigating, I was feeling the ball screws while they were turning, feeling for nicks and dings and the like. I put slight pressure on the spinning screw and Y locked up!

So far, the machine homes properly every time. I don’t believe there is an issue with the stall thresholds. Just something wonky after it gets moving.

I hope this is the 5 sec video that I wanted to upload!

Stalling out Y axis.

In the video it sounds like the stall issue that was in version 1.0.5 software. Need to change the jerk values? Any other input from anyone?

The good news is that you can create it with the joypad. When it stalls can you go in the opposite direction? If so if you move it that way an inch or so then reverse direction. Does it stall in the same place? When it stalls and you let off the joypad, what happens if you try to continue moving in the direction it stalled?

If you think one motor is turning more than the other you can unplug one of the motors and try jogging with just one.


When it stalls, it reestablishes the home in that position. Depending on what way it was moving, from that new zero, it only moves in one direction.

After talking with the girls support, they had me remove the entire X axis and home Y all by itself. Right side Y locked up. I then switched the Y wires with one another on the controller trying to get the stall to swap sides. It did not. OF tech had me disassemble the right side Y looking for a bad motor coupling connection. All seemed good there and nothing during the disassembly seemed out of place. While reassembling the right Y, I really struggled with getting the 17mm nut on the ball screw tight enough to have minimal backlash (like the left side Y) but not so tight that it caused the lock up. Let me tell you that it is a very small fraction of a rotation of that 17mm nut that is the difference between too tight and way too loose.

After a while, I think I got it just right as it seemed to be working, but I don’t get a warm and fuzzy from this fix.

Thanks again to everyone! I will keep this updated.

Lol, That was supposed to say “talking with tech support”, not girls. Wow

I actually think you’ve made real progress. Sounds like you eliminated the controller (since the problem didn’t move when you swapped cables). If it’s still happening you can swap stepper motors and see if the problem moves. If it does then it’s a bad motor. If it doesn’t then you can focus on that side of the Y axis and why it’s drawing enough current to stall the stepper. The lead screw not turning freely very well could be the problem.

When the error happens the controller is establishing a new home. This makes me think the bug is software related and because it happens intermittently. If John was the only person this happened to it would be an isolated incident but this is not. I started a thread a few months ago about random loss of position and establishing a new home and this seems the like the same thing. If its not EMI then it has to be a coding problem.

What was the stall issue in 1.05? When i first reported the issue tech support had me revert to 1.07 and this seemed to fix several issues I was having with the screen locking up from my remote computer but now I think these bugs could be related.

It’s not a software bug. It’s either a 1) bad cable or connection or 2) loose grub screw holding the motor.

I will take this apart again tonight for another look. Nothing seemed loose at all. The coupling on the motor didn’t not have a grub screw so to speak. It had a cinch bolt that pinched the coupler half (lovejoy type) to the shaft. Should there be a grub screw?

Thank you I will start looking for something loose as well. I have had this happen a total of 3 times in the 8 months I have my 1F so the problem has been very allusive for me.


I believe the issue to be a few small things that added up to the right side Y locking up.

First, there are no loose bolts anywhere on the right side Y. I have not checked the wires inside the rail but will if the trouble continues.

Second, while my right Y screw rotates the end opposite the motor has a pronounced wobble whereas the left side does not.

Third, while I was squaring the rails after replacing the X rail, I noticed something. I had one pivot screw in the front foot of my right Y (left side was still screwed down to the table). I sent X to the back and saw the rear foot move as the X rail would travel. The foot would move left and right as the X would travel front to back. I marked the extremes of the movement and got about 6mm of movement. I decided to split the difference and screwed it down at the 3mm mark.

It seems to be working better now. Backlash is tolerable and it has not locked up with the joypad yet.

I am thinking of replacing the thrust washers with thrust bearings.

I will keep posting if more issues come up.

Thanks again to the forum and OF support for the help.

1 Like

When I first installed mine with drag chains I used the stock router power cable. I experienced some similar events while jogging high speed. I have since replaced with a shielded power cord of longer length which helps in dressing things up. I have not experienced any issues aside from homing without lifting z and really nailing a locating pin for a jig. EMI is almost as much fun as a leaky capacitor.


Can EMI be the cause if nothing else is plugged into an outlet besides the controller and the screen?

I finished a carve last night with no issues. This morning, X would not home. In fact, after false homing, X would travel in both directions when pushing the joystick the same way! One time it would move left while pressing left, next time it would move right while pressing left.

I checked for loose hardware and connections and found none. I moved X by hand and felt no obstructions at all. I also checked the washer behind the take-up nut on the X ball screw. It would spin free.

Only because of my previous Y issue, I ever so slightly loosened the nut. I the. Tried homing again and it worked perfectly.

I believe the surface between the punched washer and the milled bearing base are not parallel. That coupled with the fact that there seems to be some wobble to the threaded portion of the ball screw leads me to believe this causes binding.

I will attempt to put a witness mark on the nut and all screw to indicat if anything has moved.

In the meantime, I am ordering thrust bearings from McMaster today.

I will keep you posted.

Dear John, I’m no expert, but have you checked your “square” of all your mechanical ball screws ? Parallelogram versus square screwed down to your work table that your OneFinity is sitting on, that would explain some binding issues on your ball screw

1 Like


I don’t believe this is the issue. I had the X axis off and just ran the Y. When I would run Y, the right side would lock up. Also, while running this test, the Y control wires as well as all other wires were out/ off of the machine.

I have not measured yet but I suspect bent components.

Thanks for the thoughts,



After stripping the machine down to OEM original, I decided to run the machine some more to test it out and hope that it doesn’t lock up or lose steps. It now has no after market extension cables, no accessory switches, no extra thrust bearings, every power cord is plugged into its own separate circuit on different outlets, no drag chains, no 3d printed drag chain parts, and no aluminum rails for drag chains.

I had removed the X axis completely to test the Y axis and discovered that the right side Y was the culprit and was causing the machine to lock up as in the video I posted earlier. I surmised that the take-up nut was self tightening, but this does not seem to be the case.

From the very beginning, I posted here (in a different thread) that the movement of my machine was loud, but having no frame of reference, I couldn’t say that it was unusual. I am beginning to think that the right side ball nut is messed up. That is the only thing I can think of causing the loudness from the right side Y.

That being said, I have been working with this OF for the last 3 days solid, to the dismay of my wife and child. In that time, I have broken two bits, ruined every piece of wood that I placed on the spoil board, and spent hours staring at Fusion 360 trying to determine if I did something wrong in CAM. NOPE!

The latest issue I have been having is probing XYZ. I probe XYZ with a .250" steel dowel, when done, I change to my bit of choice and probe Z with the touch plate upside down. Press play and the router/bit/Z drops below the work surface by about .200" and tries to rapid to its start position.?!? I pushed on and kept trying to get it to work. I have a name sign for a client to do, so I tried it. Fail!

After the last loss of steps/home, I calmly removed the clamps and work from the board, poured a cool and refreshing beverage, reassessed my situation, and sent OF Tech Support a note stating that I would like a replacement controller, a replacement machine, or a refund.

Something is wrong with the machine if, when moving the machine with the controller or the touch screen, the movement stalls due to some sort of electrical or mechanical lock-up!

Am I wrong?

Unfortunately this is the problem with buying a tool from a smaller company. You are the repair technician. If the repair is beyond your skills then the last option is to replace parts of the whole tool. Lots of people love Grizzly tools while there’s a large number who will not buy from them. You can find lots of people who got a tool from them and had issues that couldn’t be resolved. Even when they could be repaired the purchaser also played technician to identify the problem and replace the parts.

Hopefully 1F will come up with a solution to resolve this. Maybe in the future they can make an app for the controller to chart the stepper currents. That way they could set a range that’s acceptable and come up with a simple tool path to make sure it’s in that range over the entire path.

I had an issue with my y rail earlier on but not to the point binding up, just some excess noise in the bearings and Support just replaced it and now I haven’t had a problem since. Rather than going through all that diagnosing and ruining your work pieces just have them replace it and you will love your machine and the company.