Help! Losing “Home” during carves

Two times on the same carve my machine drops (reassigns) it’s X home position. The first time it happened about 1 hr into a 10 hr carve. This last time, I only had 2 hrs to go… :frowning:

I have made many small carves with no issues. The carve that is causing grief is a stacked text wedding sign that I’m working on. Fusion 360 cad and cam, 3D parallel tool path set 45 degrees to the grain of the board. Carve starts on the front right and works toward the top left (X starts off on the right side and move incrementally to the left)

Each time it happens, the X resets a few inches to the right and carves what should be the next, left most parallel cut.

When I stop the carve, raise Z, and bring the router home with the joy pad, X stops short of home by the distance the carve is off. I believe this has happened on Y as well, but I know for sure it was X this time.

I do have the wire extensions installed to use the drag chains. Im thinking about installing the original cables to see if the issue is the wire extensions.

Any other thoughts on what I should check?


Hi Eric - the controller most certainly should not be changing home during a cut. Since you stopped the cut and returned to the original home, which was wrong, I would not suspect wiring. It seems like a glitch in the controller. I did have something similar happen to me the other day while I was jogging, but never during a cut. Maybe you can post your gcode for a look?


Thanks for the reply Tom,

My machine also messes up when rapidly jogging. When I got my machine, the touch screen was not shipped with it so I had to run it via computer screen. The OF would stutter when rapidly jogging via the OF screen controls. Later, when I got my ga e pad, it would stutter but seemed to be less frequently.

As far as the g-code goes, I am happy to share. Do I need a photo bucket account to post pics or files? I will have to figure that out. Also, after the first carve attempt of the stacked text sign failed, I checked everything I could think of, including powered down and restarted OF. With the same g-code and same failed carve still on the table I started the carve over. It followed the previously carved area perfectly. It kept carving perfectly past the point where it messed up the first time. After about an hour, I stopped the carve thinking the issue was a fluke.

I flipped the board over and started the same g-code over. This time it ran 8 of the total 10 hrs perfectly, well past the place it messed up the first time. Then it did the same type of fail.

It seems like the 32.25” x 32.25” work area that the OF sets when homing moves to the right during the carve. After the “work area” moves, it keeps carving as it should, just way off to the right in this case. After it fails, I stoped the carve and with the joy pad, raise the Z and move the router. Moving X right causes a crash into the right side if the machine. Moving X left, it soft stops short of the end of the rail the same distance away from the rail as the carve is off. This has happened before on Y but I’m new to CNC milling and figured I did something wrong to cause it.

Thanks again,


I was going to upload the g-code but the file is too large :stuck_out_tongue_winking_eye:

In the top pic, just to the left of the strip of OSB, you can see where the machine jumped back about 6” and continued cutting its next pass. It cut through the O in October and made a few other dings.

The bottom pic is the first time it skipped or lost home. This is the one where I stopped the carve and restarted it again from the beginning just to see if it would mess up in the same spot.


There has been a few that defy easy explanation, but would need to know more about your machine. One thing that can happen is non-shielded cables touching or overlapping others and “transmitting” across them. It usually shows up in VFD setups more than others, but it’s been found when a dust hose crosses too closely to a control cable and sets up a static input to an axis. It can literally input a step or so when it didn’t come from the controller. Very difficult to analyze, but could be your problem.


I’ve been talking to OF support. They asked for a video to show the issue. I was moving the machine with the joy pad, dust collection and router were off. The Y motors stalled out while moving. Not sure why it does that but I believe this is my issue.

I will be aware of hoses and the like while I am carving to see if anything correlates.


John - have you checked all the connections? Clearly what you are experiencing is not normal.


If an axis stalls during use it will draw the same amount of current as it draws when homing. While doing your cable test I would also manually try to spin the stepper motors to see if something is binding. Also I would check to make sure the coupling between the steppers and the lead screws are tight.

One thing I don’t like on the 1f, and it’s minor, is the collar that stops any play in the lead screw. It’s just a hole through the center and two set screws that push against the lead screw threads. I would rather see this kind of clamp. But I think it’s only used on the Z axis so it shouldn’t be your issue. But I would still check all 3 axis to make sure there’s no play.


I actually unplugged all of my extension cables and installed my OEM cables, checking all connections along the way. This did not seem to help. I was trying to catch it fail on video but missed it (of course) but I was able to get a video of Y locking up mid stroke.


I didn’t take anything apart to check for hardware issues but I did push and pull to “feel” for play in the system. I did not see or feel any. I had been emailing OF support the past 2 days (excellent support, 5 stars for OF here) so I was waiting on them to trouble shoot before I took anything apart and slowed the process down.

After seeing the video, I was asked to pull the routers power cord out of the drag chain and plug the OF controller, vacuum, and router into different outlets. They thought EMI as did a previous post mentioned.

I did as they asked when I got home from work today and OF has not skipped a beat…so far. I put the first failed sign back on the table and re-ran the same g-code s the last two tries.

I will post back tomorrow with the results.

Thanks all who helped out! And thanks to OF tech support!

1 Like

Brushes on motors can cause problems. I didn’t realize you were using drag chains. If you do go back to them I would suggest braided shielding sleeves for all the wires. One of the drawbacks to a router is the power cable isn’t shielded wire. Hopefully you’re all set now.

1 Like

The stacked text wedding sign carved with no problems! EMI, at least at this point, seems to be the culprit. Thank you to everyone who took part in this!


I am trying to plan my next move regarding wire management. Would grounding the motor control wires solve my issue? Does plugging in all of the 110v plugs into one outlet cause much concern? I will have to find a source for shielded power cord for the router, or print brackets to fix the cord to the outside of the drag chain.

I will carve the sign again on a good piece of wood and will post my results!

Thanks again,


1 Like

I’m glad you finally found the culprit Eric!

I’d like to share my unsolicited two cents regarding your machining strategy if I may, feel free to ignore me.

A raster toolpath like you are using is effective, but definitely not the quickest method on a 2.5D carve. With some modified machining strategy I’d estimate you could drop your cut time into the 3 hour range or better.


I also experienced this exact problem. My machine losing home during a long carve and jumping to a new position. I have had this happen a few times over the last few months but have never been able to narrow down the issue. I also was having issues with my remote window locking up and after many emails with support they suggested I revert back to 1.0.7. This seemed to fix the bug but now I am wondering if I also have emi issues and if this is something that needs to be addressed regardless. What would be the optimal setup to avoid emi issues?

1 Like

I am very new to the CNC world and learned Fusion 360 from YouTube. I am all ears when it comes to learning faster or better CAM practices.

The stacked text sign was my 3rd project that I had ever CAD/CAM’ed in my life!

I tried a 2D adaptive with a finishing pass but had bad, very fuzzy results. I have also tried Easel just to see what it was like.

I’m very interested in any information you have or resources I should look into that will make me better!


I have done some research into emi and rfi. There’s plenty of confusing info out there and I’m no expert. Some of the easy thing to do are grounding your machine to a single point, adding ferrite cores to your steppers and power supply cords. Make sure your power cords don’t cross over your stepper motor cords or any other wire you maybe using in your setup.( line management)

Well, I got home tonight and was setting up for another carve and it did it again while I was jogging the router around. Y lockes up mid stroke and “cries” until the joy pad is let go of.

The wires are as they were last night when I finished the carve, nothing was powered on besides the controller. It seems to be happening more frequently as well.

EMI may have played some part in this but there are deeper issues at play. I have reached out to tech support again.

1 Like

Is there a way to post a 5 sec video in the forum?

You need to post to YT or something like that and then link to the video.

Definitely seems unrelated to EMI - that would be very temporal and go away when the wires are jostled or moved.