Huanyang VFD to Controller

Very true. I will purchase whatever small amount to give that a try as well I don’t own it

One Yang instructions don’t clearly show a ground terminal other than what I would interpret as the DCM? (digital common). So my ground is connected in the controller but floating in the vfd until I can identify the correct common terminal to link the two together.

As for my RJ45 or ethernet connection it is connected to my home network and I can control it via a web interface. I’ve connected through it through my iPad as well as through my laptop now that is on my network.

As RS-485 serial line is a balanced connection it does not need a common ground, but if there is faulty grounding in the system i.e. ground loops, this may induce hum which can deteriorate signals.

1 Like

There’s nothing in any one of the diagrams that references sharing a ground between the vfd and the controller that’s the odd part

Although it is not needed I would have assumed that they would have at least wanted a common ground source between the two

Hey Steve,

Iv’e been thinking of this too, I’m about to wire my control cabinet too.

(Source: Omron MX2 User’s Manual)

Since the Onefinity Controller has a protective earth (PE) connection to its case, and the VFD too (at least mine, your VFD too?), they are both earthed and bonded.

I’m also having this issue, modbus timedout with no spindle control, spindle and vfd work fine when set to be controlled via VFD buttons. All settings to communicate with the onefinity controller and shielded cabling are correct.

My VFD has a white case and the settings are displayed as F001, F002 rather than PD001, PD002 etc but all settings are the same. There’s also some jumpers visible on the vfd, jumper 4 seems to relate to RS485, it has a setting of ON or OFF, I have tried it on both, still no joy. At a loss to know what’s wrong.

Hey Jason,

it may be a jumper for the Termination Resistor like my VFD has? I could only say that by looking at the pcb. You don’t have a manual?

I assume you have set
PD000 to 0 (unlock parameters)
PD001 to 2 (Command source is RS485)
PD002 to 2 (Speed source is RS485)
PD163 to 1 (Communications address 1)
PD164 to 1 (9600 b/s)
PD165 to 3 (8 Bit, No Parity - RTU)

Did you try to change the Interface settings e.g. go up to 19200 Baud (PD164=2) or to 38400 Baud (PD164=3)? Ensure that the setting in the Onefinity Controller’s Tool Configuration Tab is set to the same Baud value as in the VFD setting.

Thanks for your reply, I hadn’t tried changing the baud rate when I posted but I have just tried it now without any success.

I can’t find the exact VFD drive manual but it is the same drive as this one, just badged different

Here is the part about J4, I’ve tried it both on and off.

I don’t really understand rs485 to well and I am presuming I have used a suitable cable. Its 3 core CY 0.75mm shielded, I have not connected the earth or the shield either end. Trying to see if this is correct is a minefield searching Google with lots of conflicting theories about connecting the shield and/or earth core one end to a GND terminal (not PE?), both ends and not at all, totally confusing.

Distance between VFD and onefinity controller is only around 6 inches but the cable is about 4ft in length, not coiled up.

As a test I reset the OF controller to factory setting ith the breakout board unplugged, then configured the TOOL for the VFD. This gave me the exact same timedout message on the OF screen, whether this means it is a cabling issue for sure I don’t know :man_shrugging:

Hey Jason,

thank you for sharing your information. I downloaded the Manual for my collection (I collect information in order te be able to write a wiki entry on spindle and VFD setup).

So my assumption was right, the DIP switch “J4” is the termination resistor. If you have only one VFD connected, then it is on one end of the RS-485 network, so the Termination Resistor should be turned on.

As for cable, the RS-485 Connection is a balanced line which does not need a common ground but in order for the shield to work it must be connected to ground somewhere. In order to avoid ground loops, shield may be connected on one side only.

I would connect it to the VFD’s case which in turn should be connected to the PE of your workshop wall outlet. It has a PE connection I hope? Your VFD has a PE connector as it sais in the manual on page 7:

Earthing terminal
VFD housing earthing terminal must be earthed.
Note: Screws on main control board serve as PE terminals for that of 0.4 ~ 1.5kW.

Also the Onefinity Controller is earthed, it has a PE pin and I assume that it is correctly connected to the case, so the case should be earth.

You may also connect the shield to the “Shield” pin of the breakout board adapter.

I really hope that the RS-485 connection can be made to work.

Did you already try to swap 485+ and 485-?

Looking on builbotics they say connect shield both ends, one end to GND of VFD and other to pin 25 breakout, maybe I should try this. I didn’t try swapping + and - as the OP above said that did not work.

Edit: not pin 25, the GND pin on the DB25 connector!

Both VFD and OF controller are earthed, I live in England, almost everything is earthed here as standard.

Hey Jason,

I just read the User Manual you posted above for OMC-Stepperonline V70 VFD. It seems a little bit as if the Huanyang VFD (and the Huanyang manual) was a more simple clone or counterfeit of this VFD. It is true as you said that the most settings have identical numbers (“PDxxx” on the Huanyang instead of “Fxxx” on the OMC V70), but the OMC V70 has much more capabilities and a good manual. It is also capable of Vector Control.

The OMC V70 Manual covers models from .75 kW up to 7.5 kW but on the OMC Website there is only the .75 kW model. Did they stop their production?

Anyway, the ModBus RS-485 settings F163, F164, and F165 are the same as on the Huanyang the settings PD163, PD164, and PD165:

However this setting, F169, does not exist on the Huanyang:


Did you set it to “0”?

Mmm that’s a setting I did not realise may need modifying from default, mine is not the stepperonline badged version, my manual is virtually the same just the names are different on branding…H100 vs V70 as per the manual I referenced, I can’t find the manual online for my one but I read it could be a more updated HY.

I will give that a try shortly, good spot.

It was actually already set to standard mode, I tried both settings to no avail. I may carry on with the setting up and run the spindle manually for now, keen to get a wasteboard down and do some test pieces.

Hey Jason,

I am so sorry that you have not yet had any success transferring control of the VFD to the Onefinity Controller via RS-485 / ModBus.

You already checked every step in

Of course, if the VFD and the spindle work manually controlled, then the CNC machine is not useless, but that’s not how it should be operated.

  • To regain control “Run/Stop” and “Speed” using the front panel, you’ve set back both F001 and F002 to “0”, is that right?

  • In order to let “Run/Stop” and “Speed” be controlled by the Onefinity Controller via RS-485/ModBus using “M3 S10000” commands, both F001 and F002 were set to “2” is that right too?

Yes F001 and F002 were set to 2 when testing comms, as this model has a control knob the setting for manual speed F002 is 3.

Ah okay, this one has a potentiometer on the front panel.

At this point I would already have connected a RS-485 diagnosis device or an oscilloscope. If you have neither, I assume you want to check the VFD on another Controller/Buildbotics/Raspi or the Onefinity Controller with an other VFD…

I had similar timeout issue when I first install my VFD. My breakout board did not make contact with controller connector. At that time I noticed that I needed to apply pression on the breakout board to get OK status. During my test I was able to get it work while the nuts were removed. I finally replace both of them with shorter one (few mm) that were initially on my computer monitor.

So Check this:
A. First check if those nuts are fully tighten
B. Second, check if the metal part is near enough to the connector.

Good Luck


Hey Ghislain,

wow, if that is the cause of the issue, you have to figure it out first. It could be that you made the whole thread redundant, because if the thing is not plugged in correctly, everything that was speculated above is totally superfluous! Thank you very much Ghislain!