Huanyang VFD to Controller

I tried pressing on the dB connector, still no joy so I have now checked continuity from the OF controller board to the VFD and the connections are good, still getting timedout message trying to connect :sleepy:

Hey Steve,

did you get the RS-485 connection to work finally?

Hey Jason,

nothing new as for RS-485 Connection?

No mate, I’ve exhausted all settings and checked cable connections several times, I’m really not sure what else to try without another driver so just gonna run manual for now.

1 Like

Jason,

Not to prolong the misery, but there is a physical jumper in my Huan Yang (J1) That the manual says is supposed to be set to 1-2 jumped for remote management instead of 2-3 for local. 2-3 is how it was set at the factory. Now, in my case, it didn’t make a bit of difference. The Onefinity controller saw the HY on the first try and I hadn’t moved the jumper to 1-2. Maybe you might find success by moving the J1 jumper to pins 1 and 2?

Jim

Hey Jim,

as you stated here, this jumper does not affect the serial communication between VFD and Onefinity Controller.

Nonetheless this jumper, which could not be found in the Huanyang Manual that can be found at Buildbotics or at Automation Technologies Inc., is of great importance for all who have a Huanyang VFD Model with a potentiometer on the Front panel:

A potentiometer can be connected to any VFD, but those models who additionally have a Potentiometer on the Front Panel they need a Jumper or something that lets you choose which potentiometer to use: The one on the Front panel, or the other that you wire to the Analog Terminal Inputs:
!Huanyang_VFD__Basic_Connection_Diagram__With_mark_on_Analog_Input_Terminals
Source: Huanyang Manual, page 12.

Note that if you bought a VFD without potentiometer on the Front Panel, don’t worry, you can at any time connect a potentiometer to the Analog Terminals showed above.

So of course I saved well the information about the jumper you gave me, in order to make it available.

1 Like

Yah, Aiph5u, just grasping at straw, feeling bad for Jason. You are right though. It is related to the potentiometer - not communication with an external controller.

The collets came today. I’m going to install the 80mm mount and the spindle right now. Fingers crossed.

3 Likes

Opportunity per region for a side hustle @Aiph5u : “Spindle Installer”. I’m sure many would pay a small sum to offset days of fumbling through VFD settings.

Saying that I think I can download my settings from my VFD as backups. Is this possible with others? We could then share the files plus a few tweaks (but it would be a downer on the side hustle :frowning:)

Thanks for asking, no I have not. i moved forward with carving so I can get the beast running & cutting. All working great. But, no control from the Controller to VFD. I tried termination, all baud rates, shielded-twisted cable. All VFD profiles in the drop down. Changing address. All equated to hair loss.

2 Likes

I have to say, I’m always very sorry when someone doesn’t get it to work. And of course also annoying when you can’t say why it doesn’t work.

1 Like

No success. Sorry, but I replied to the email instead of the post. No luck. Only tears and sorrow.

Well, either the signal is not leaving the breakout board, or the VFD is not receiving it. This is a pretty easy setup - I doubt by this time that you haven’t gotten it. As a trouble-shooting step, my next try would be a different VFD.

I have a 1.5kw 110v VFD that I’m not using at the moment - if you’ll pay shipping I’ll let you test with it…

1 Like

Sorry for bumping an old thread, but I spent many hours on exactly this issue and finally managed to find a solution. If anyone is still stuck; the cause of my issues turned out to be two-fold:

  • I had a good signal on the 485+ pin, none on the 485- pin (checked with oscilloscope).Turns out the DB25 connector had some poor solder joints on the board, I applied some new flux and solder after which the signal was fine. (I think this is why some people are saying you need to screw the connector down tightly… this may push loose pins back against the pcb).
  • Still had the “timeout” message when trying to connect to the VFD. Changing the baudrate from 9600 to 19200 on both sides (value 2 for F164 on the HY VFD) solved this. I haven’t checked whether the actual operation worked at 9600b/s, maybe it’s just the timeout label that misbehaved at the default baudrate. I can’t explain this behavior at a signal level, lower should be more stable if anything. The Onefinity does seem to inverse the polarity each “ping” message, probably so you can connect the + and - (A and B) the wrong way around and it will still work, but this means half the messages are garbage and will not receive an answer. Maybe that triggers the timeout at the lowest baudrate; just guessing.

Hope this helps someone!

3 Likes

Hey Hans,

welcome to the forum!

I assume you mean the board of the breakout board adapter (not the Onefinity Controller Mainboard).

This is very interesting and precious information for the many that report failures with this. Thank you for reporting this!

I already thought that many of the issues that appear because of the problems that Ghislain reported here would not have appeared if people didn’t use these cheap breakout board adapters but wired a good cable to a branded DB-25 plug directly.

Hey thank you very much for posting on thread I have still struggled with this and have left for dead since I didn’t think there was a solution I’ll give that a try and again report back really do appreciate it have an awesome day

1 Like

Thanks.

I actually was talking about the main Onefinity (Buildbotics) control PCB, not the breakout board adapter! I should have been more clear on that. Also, I can imagine not everyone wants to try this repair for that reason. After previous experiences I expect zero support or warranty from Onefinity, so I do not mind taking my machine apart and making changes to it.

Hey Hans,

really. Thank you for reporting this!

Note that they don’t buy the mainboard from buildbotics, they make their own. See here vs. here. You can see routing differences, e.g. since they moved away external power connector and wanted the other connectors (touch probe, laser, L1 & L2 etc.) externally on back plate.

Thanks for this helpful thread. I’m getting rs485 timeouts trying to get it setup, and this gave me a lot of things to try. Is there a way to test/debug if the controller db25 output is getting signal without an oscilloscope? Or maybe I’ll need to try connecting the vfd to another controller.

Hey tmuka,

yes, if the controller gets the signal, it ceases to report timeouts. Ensure having the right settings for serial connection.

I would think of hardware failures like bad cable and also what Hans reported above:

Hans made clear that he means the DB-25 on Onefinity Mainboard, so I would check continuity between mainboard pcb points and pin outputs of DB-25 connector with a multimeter (set to ohms). See here for pcb layout & schematic in order to find where pins 13 and 14 reside.

Did you already check what Ghislain reported here?

If you have the opportunity, it’s the easy method.

General hint: When attaching ModBus serial line, make sure devices are both grounded and please always ground yourself with a antistatic wristband and avoid the loose cable ends touch the carpet. Wired network connections are ESD

1 Like

Thanks so much for the help! Fortunately I rechecked all my connections today, found a loose terminal, and it’s working now!

I did learn that if my manual gcode S1000 M3 is below the minimum speed in the controller tool configuration (default 6000) it will fail to work without any error message… S6000 M3 works fine!

3 Likes