I have a woodworker that I cannot home. I have been trying for the past week to get it running with no luck

when p press home it sets the router however nothing else moves.

1 Like

Did it work before and stopped working or is this a new setup?

it has never worker new machine

I would suggest checking the cabling connections to the controllers and the steppers to ensure you have them fully seated in the correct locations. The connectors on the controller are grouped close together and you may have them plugged in the wrong locations.

If you haven’t come across them already there are a bunch of videos made by Onefinity on how to assemble and operate the machine.

1 Like

Derek, I can move the machine all over the place with the joy stick just gives me shit when I try to home so I can do my spoile board.

Did you try adjusting the voltages for stall homing? There an official Onefinity video for adjusting stall homing.

I believe it had me adjusting amps, the term was max soft limit they started out as "0"s. As for the video if I had it here it would have been worn out from watching it so many times. Nowhere does it state stall homing though.

Happiness is having some to love, and share you life with…

I changed the currents back to 0 on Y, and upped the voltage from 2.2 to 2.3 Homed the machine and Y did not move.

Happiness is having some to love, and share you life with…

You are correct. I believe it is amps. I’m having a little trouble following what you said in your comments though. I assume this is the video you watched?

Assuming that’s the video I’m not really sure what to tell you from there. I’m a novice at this so probably not too much help. Did you reach out to Onefinity support? They’ve helped me with a few things. Usually they have been pretty good.

You set the stall current to 0 amps? The default is 1 amp…

If you have followed the stall homing video correctly and still no-go on homing but can move to all corners via game controller, I would re-flash the SD card and start from a fresh software install. the software and how to videos are available in the forums, perform a search.

Hey David,

did you consider this:

Hey Eric,

I don’t think that this will help.

The reason why users sometimes are told by Onefinity to reflash the entire SD card is because the package ‘onefinity-firmware’ is not packed as .deb package, so cannot be upgraded (except by overwriting the installation by unpacking the tarball) and especially can not be downgraded with ‘apt-get install onefinity-firmware=[older_version]’). That’s why they tell the users to overwrite the whole OS on the SD card that often :frowning: When the buggy 1.0* firmware was revoked by Onefinity, you could not downgrade the onefinity-firmware package as would have been the way to go if onefinity-firmware was correctly packed as .deb package. I think neither the Buildbotics Developer nor someone at Onefinity knows how to pack their firmware as a .deb package. Therefore, their firmware is installed with the ancient “unpack tarball” installation method and to avoid parts of a revoked version to remain in the system, they tell the users to reflash the entire operating system :frowning:

Another opportunity to simpy overwrite the whole Operating System with a virgin SD card image is a bug in the buildbotics-derived Onefinity Controller firmware. Everytime when you upload a g-code file, it creates a subset of files that the firmware uses to run the g-code later. This sometimes leads to strange effects when you upload a file with the same name. Sometimes you would want to erase such files, especially when you know you know that you don’t need them anymore. But in this case you can erase the contents of the corresponding directories and don’t need to reflash the entire SD card.

On the other hand, reports of failing SD cards are very frequent. In this case I would not reflash the same SD card, but buy a high-quality SD card instead and put the system image on this new card.

1 Like


When I received my 1F I could stall home in X and Y, but not Z. Turned out to be a bad cable. With the new cable everything worked as it should.


There’s more than one reason to start with fresh software! Getting him to a fresh “factory” install, where the software should be PRIOR to any settings changes, is the best way to be sure he’s starting with “factory” settings (obviously, more that the “stall-current” has been changed). Besides, he’ll need to know how to do this down the road sometime for upgrading his software version.

1 Like

Hey Eric,

Of course it does no harm if you know how to write a SD card image dump to a SD card.

But you don’t need to overwrite the entire Raspberry Pi Operating System Installation in order to reset to the default settings (this is not MS Windoze :slight_smile: ). “Reset” or “Restore” the Onefinity Settings is enough:

Image 1: The ADMIN page on Onefinity Controller with the “Reset” and “Restore” configuration button. Here you can also save and make a “Backup” of all your current settings.

Image 2: Selecting a default configuration for a “Reset” to defaults of all settings (newer firmware versions should show the “PRO/Original” models)

If you have a defective SD card, rewriting the SD card image is of little use as errors will reappear.

1 Like