Machine will not restart after hitting physical e-stop button

Hello all. I was attempting to run a spoilboard flattening toolpath and it started going haywire. I kind of panicked when I saw that it was about to hit the screws on my spoilboard and hit the PHYSICAL E-STOP button on my controller. When I tried to turn it back on, there was no response from the controller. I cant move anything. I’ve tried resetting the physical e-stop button but I still get nothing. Can anyone advise?
Thanx in advance.

Hey Larry,

as Onefinity stated here, their Hardware Emergency Stop button is not wired to the “estop” input of the mainboard, but interrupts power to the entire controller at the internal power supply instead. Therefore it is not advisable to use this big red E-Stop button on the controller’s case AT ALL, for the reasons explained here.

What I would do is the following:

  1. Try to pull up the physical E-Stop button as much as possible and turn it to the right. If this leads to no success,
  2. disconnect the Onefinity Controller from mains electricity, open the controller case, loosen the two wires from the back of the physical E-Stop button and splice them together, thereby bypassing the E-Stop button. Now connect the mains electricity again and turn the controller on. If it runs now, then it was the E-Stop button which was damaged by hitting on it. This has happened to others before.

If the controller still doesn’t run, you may check the power switch. Do you have the Onefinity Controller version 4 (or lower) which has a rocker switch for powering it on? If so, with disconnected from mains electricity, you could check if it failed because of dust inside.

Do you have a multimeter? If so, if you switch it to ohms (resistance), you can, with the controller disconnected from mains electricity, measure at the two poles of a switch and see if it works. In case the switch is switched “on” the resistance measured will near to zero. If you measure nothing, the switch may be defective.

Also you can use a multimeter to check if the required voltages are there. Caution! It is dangerous to measure with the controller connected to mains electricity. But this way you could check, with the controller connected to mains electricity and the switch in “on” position, if the voltages expected are there. Inside the Onefinity CNC Controller, there is a 36 V version of Meanwell LRS-350 power supply.

  1. Two of its terminals are called “1 AC L” and “2 AC N”. With the multimeter set to “600 V AC”, measure if your mains electricity is there by inserting the multimeter probes to these two terminals. It should show something between 220 and 240 V (100 – 120 V in North and Latin America and Japan).

  2. Two of the terminals are called “V+” and “V-”. With the multimeter set to “50 V DC” or “100 V DC”, measure if 36 V is there by inserting the multimeter probes to these two terminals.

If you successfully measure your mains voltage under 1.) but not the 36 V under 2.), then the Meanwell power supply is defective.

If you measure successfully that both voltages under 1.) and 2.) are present, then the failure is further down the road, i.e. at the switch or on the mainboard. Then it depends whether you have the rocker switch version (v4 or less) or the push-button version (v5). If the first, check the power switch as described above. If the latter, find the jumper J18 on the mainboard and short its two pins with an insulated electrician’s slotted screwdriver.

1 Like

This is unbelievable. Therefore it is not advisable to use this big red E-Stop button on the controller’s case AT ALL, for the reasons explained here

In the event of a tool crash, what is the best method to stop the movement of the stepper motors as quickly as possible, without causing damage to the electronics.
Does the “big red E-Stop button” do the exact same thing as a power failure? wiring up a main panic cut out for the power strip that everything is plugged into, including the router?
A tool crash in almost every type of machining is known to be a reality, a quick response is needed, and should be crystal clear.

Push the digital estop button in the upper right of the touchscreen

Great, thanks, what then is the purpose of the manual e-stop on the controller? and when should it be used? Are there risks to the electronics when using it?