Motor Comm error, starts up in e-stop mode

Hi there, after assembly things seemed to be working normally. We loaded a file via USB for the first time, centered the router via a controller, and hit play… and nothing happened. After poking a few buttons the last message we got was something to the effect of ‘cant run program during a homing cycle’. We reset, and from then on the program seems to start up in e-stop mode with the ‘power shutdown’ message, all the axes are in shutdown state, and the debug log shows com errors with the motors. The indicators show motor under volt, motor overload, and power shutdown are true.

I’ve tried multiple restarts, reinstalling the firmware, unplugging and replugging all cables, resetting to defaults, no change anywhere. Any thoughts on what else I can try?

Are you following these steps:

  1. power on
  2. home the machine on all axis (hit the top house icon if you closed the prompt)
  3. zero x and y axis
  4. probe or zero z axis
  5. hit play

Your comments make it sound like homing or zeroing were not done completely\correctly. When ready to cut everything should be lit up green.

I was able to reach support via email, it looks like there’s a hardware issue in the controller. They’re sending out a replacement.

1 Like

My E-Stop was on when I got it. Had to twist it to get it to pop up.

Mine was on too, like Frank’s. But it sounds like you got it sorted out.


I had similar issues when I received and installed my onefinity last week. Worked it through support through email. They decided it was a controller problem and immediately sent me a new one. I installed it this week and it is working perfectly. Great and prompt support. Thanks Onefinity!!!


Hi ,my machine is doing the same, estop has disconnected all motors and will not lead or drive ,tried all the things you did and nothing ,how did you fare out,mike

Ended up contacting customer support and got a replacement, works great now.