OOPS BB problem?

Just made a rather large error, told the machine to move with a g0 command with the bit too low & spindle off, crashed against my spoilboard square & bounced the x axis stepper motor BRRRP. hit the OShit and moved everything into safe place, restarted & homed, did not like the Y home stop, rebooted re homed OK
Deleted all programs. & tried to load a program, the usual box the file would display shows nothing but a small down arrow & the CNC says “simulating” but stays at zero. Press the small down arrow and the file name appears in a box beneath the usual file display box, hit the file name which comes up into the usual box but hangs saying “simulating” frustrated wanted to do a valentines thing, any suggestions short of big hammer or dynamite>

Reflash the sd os to reinstall the firmware.

Oh great gotta bring in a tech for that.

Ouch Tony!
Your first prediction is correct - it’s the big hammer!

I just went thru it this weekend for the first time.
Here is the post I followed and it worked fine:
How to reflash the operating system on the Onefinity BB controller (Full SD card image)

The first laptop I used - the SD card reader didn’t work, I didn’t know it - that slowed me down. Once I got a laptop that worked - it went fine - just takes time.

Once I get everything setup the way I want it I will take the SD card out and make a backup using this post:
How To Backup the Onefinity Micro SD Card

That will get me backup and running faster.

Thanks for responding so quickly, just did not like the fix.

1 Like

Down for third day now, no one that I know of within 60 miles round trip that has an sd card reader/wrier. Be really nice if onefinity stepped up to the plate and offered to fed x me a couple one to run and one for spare. Do I have to go out and buy a new computer so I can flash sd cards when needed.
Would happily pay for a couple of cards and the freight…

Hey Tony,

you simply need to log in and become root and delete the contents of the /var/lib/bbctrl/plans and /var/lib/bbctrl/upload directories. No need to reflash the entire Operating System Installation (except if the SD card is failing, but in this case re-flashing it would make no sense either).

If you are on a display directly connected to the Onefinity Controller, you can open a terminal by typing this on a USB keyboard you attached to the Onefinity Controller:

<Ctrl>-T <Ctrl>-C

If you are on a remote machine, you can get a terminal by logging in via ssh as bbmc@onefinity.local

  • on a unixoid shell with the command:

ssh bbmc@onefinity.local

and password: onefinity

  • or under windoze by using PuTTY with the credentials:

remote host: onefinity.local (or its ip address)
user: bbmc
password: onefinity

When you are in the terminal, you type:

sudo -i

(password for sudo -i: onefinity. Ignore the warning about the password for ‘pi’ was not changed yet. You are root@onefinity now.) Then continue with entering:

rm -I /var/lib/bbctrl/plans/*
rm -I /var/lib/bbctrl/upload/*

The “-I” option (for “interactive”) on the remove command (rm) is to make ‘rm’ ask if you are sure before deleting. Without this option, ‘rm’ behaves like all UNIX commands: If nothing goes wrong, it makes no output. You can also use “-i” instead of “-I” but then ‘rm’ will ask if you are sure for every single file which may take longer then.

If you are interested to see what files are in the directories before deleting them, you can do:

cd /var/lib/bbctrl/plans
ls -l | less
cd ../upload
ls -l | less

Inside ‘less’, use space bar or PageDown key to scroll forward by one page, and use “q” to quit ‘less’.

If you want to know what the command ‘ls’ is for, type:

man ls

‘man’ means “Display the Manual Page”. This works with all commands. e.g.

man sudo

means “Display the Manual Page of the command ‘sudo’.”

See also:

1 Like

@OnefinityCNC ,
Not feeling very good about onefinity right now, when I first got the machine and downloaded the 1.1 as per the prompt. I was able to get a local to flash the chip for me which absolutely should have been blocked.
Now 30 miles each way to the nearest town which does not have a reliable computer store, and which I would have to pay by the hour even if the could or would re falsh it for me. When I bought this beautifully designed and crafted the onefinity I expected to at least get some custormer service.
Now, stuck in the mountains of BC it is time for Onefinity to demonstrate that it does have a human side, get off its engineering high horse and actually go the extra step of shipping me at my expense a couple of sd cards, which they could easily do, Come on onefinity time to help out a customer.

Have you been working with support via email? The forum is not their official support channel.

I would strongly encourage you to order an SD card reader to be able to do this yourself as it appears you have needed it more than once. I agree it is frustrating but it is also one of the things you can view as a feature as the alternative would be to burn the code in a non user serviceable chip at which point your machine would be harder to repair. Unfortunately there is a bit of work involved that is a stretch for many users though.

1 Like

@Hermsen.BJ @OnefinityCNC
The reason I bought the onefinity is because due to age related probs, have difficulty with dexterity, and the CNC allows me to keep makning nice things even though this becomes more difficult even to use a keyboard, flashing a card is a non starter as I fear a wrong keystroke, which are common as they move the keys around on the keyboard

This is a weird rant thread.

  1. just buy an adapter. It’s $4 on amazon. Amazon ships to anywhere in the world. Here’s a link to one Amazon.com
    If you can’t flash an sd card following their detailed walkthrough and itemized YouTube video, actually using the cnc will be very difficult. The first part of cnc stands for computer.
  2. It sounds like you have yet to contact their official support channel? It would be faster and take less effort than constantly posting here. In case you didn’t know how, here’s the link to support. https://www.onefinitycnc.com/support

Thank you for your response, I have learned from you by watching youtube.
One of the reasons I bought a cnc was that it would force me to relearn computers (pre windows was quite adept)
Living in Beautiful remote BC canada, even Amazon is not great & takes weeks here or takes a trip across the border which is much quicker.
The problem was caused by hitting the wrong key because fingers these days sometimes have a mind of their own.
I went through exactly the same sd card flash problem when I first bought the machine and they put an update button on screen popping up when I first turned on the machine after bolting it onto the table.
Any how they are now telling me they will send me cards which would have been nice a year ago.
Regards and thanks for the educational work you do.
Tony Aldridge

Hey Tony,

I would have asked how exactly you all can see a causal relationship between this crashing event and a damage of the Operating System’s SD card filesystem, requiring re-flashing the entire SD card. I’d REALLY be interested in someone explaining that to me!

Ah, here we have the culprit. As Onefinity confirmed here, hitting the red mushroom-shaped button on the top of the black Onefinity Controller case does not trigger the buildbotics “Estopped” mode, but only cuts the DC power to the Onefinity Controller mainboard and does nothing else (and unlike in real buildbotics “Estopped” mode, hitting this button does not stop router and spindle!). Also it brutally cuts power to the internal Raspberry Pi which can cause filesystem errors :cold_sweat:. That is why I repeatedly warned about using this button AT ALL and recommended wiring this button to the “estop” pin 23 on 25-pin I/O port instead, which then would trigger real buildbotics “Estopped” mode (which also stops spindle and IoT-relay-attached router then!) and does not brutally cut power to the internal Raspberry Pi, so won’t cause filesystem corruption on the SD card.

Just like any computer, interrupting power on the internal Raspberry Pi 3B inside the Onefinity Controller during a write operation on the filesystem is likely to cause filesystem corruption with possible data loss. THIS is likely to entail the necessity to reflash the entire SD card.

So, Tony, if you intend to further use this non-smart brutal button on the top of the black Onefinity Controller case, that DOES NEITHER trigger buildbotics “Estopped” mode (if you don’t wire it to estop pin 23 on breakout board adapter instead) NOR stops router or spindle on emergency, I strongly suggest to always have a SD card writer on hand, as using this button is likely to corrupt the filesystem of the SD card everytime you use it.

Alternatively to hitting this malwired button, you can click on the red/yellow “Estop” icon on the top right corner of the screen. This one REALLY enters buildbotics “Estopped” mode:

More Information

Connecting Emergency Stop button to the Onefinity Controller breakout board

to trigger real “Estopped” mode

To use the buildbotics “Estopped” mode with your red mushroom-shaped Emergency Stop button, you wire it to ‘EStop’ (Pin 23) and ‘Ground’ (Pin 25) (=Logic low) on 25-pin I/O port (e.g. via the breakout board adapter)

Image: Emergency stop switch with case for external mount

If you connect a “Normally Open” Switch (NO), in the “I/O Configuration” Tab, “estop” on the SETTINGS page must then be set to “normally open”. If you connect a “Normally Closed” Switch (NC) you must set it to “normally closed”.

Excerpt from Buildbotics 25-pin I/O port (breakout board adapter):





Open, VIL Emergency stop switch

20+3.3 VOV3.3 3.3 volt source, 26.1 ohms source impedance (see note)

Note - The following table defines the logic values that are used.

VOL00.76 VDCLogic output low
VOH2.6 VDC3.3 VDCLogic output high
VIL00.6 VDCLogic input low
VIH2 VDC3.3 VDCLogin input high
V3.33.3 VDCVoltage found on V3.3 Output when unloaded

Thank you, that is most helpful.
Fortunately onefinity is going to send me a couple of sd cards all flashed and ready.
Went through a very similar situation with 1f a week after I bought the machine.
Have mashed the oshit several times in my CNC newly found career, only prob I can see now is that the screen is not very responsive and when everything is gang a glee there is real satisfaction in mashing the hardware.
As always your advice is welcome and well thought out.