Screen aspect ratio fix for large monitor

ref. buildbotics forum

  1. SSH to your cnc using user and password.

  2. Run the following, ignore inside the brackets:
    a. sudo mount -o remount,rw /boot [makes the file system writable]
    b. sudo nano /boot/config.txt [edit the config file]

  3. Scroll down about a page and you’ll find something similar to this:
    framebuffer_width=1280
    framebuffer_height=720

    Change the values to your screen resolution. Ctrl^o to save, confirm changes with Y and then Ctrl^x to exit the editor.
    I replaced 1280 with 1920
    I replaced 720 with 1080

  4. Run the following, ignore inside the brackets:
    a. sudo mount -o remount,ro /boot [mounts file system as read only]
    b. sudo reboot [resets the machine]

3 Likes

On most screens, you can actually just comment out the framebuffer_wdith and framebuffer_height lines, and the graphics system will just flex to the resolution of the screen.

1 Like

I have hooked up a 19" Philips monitor to the machine and it is working but the image is actually too big for the screen. On the left flyout menu, items are displayed but missing the first characters: i.e.:

  • otors
  • ettings
  • etwork, etc.
    Would this fix this issue?

Also, I tried to adjust the width and height using the monitor itself, but there are no controls available within.

Thanks

Have you ajust your setting according to David Carley recommandation?

No, not yet. I wanted to check if this would resolve the issue first :slight_smile:

I had the same issue. I used an older TV that we no longer needed. It is 34", way overkill but it was not being used and works well. Both of the above changed the display resolution but neither helped the flyout menu on the side.

There is a section of the config.txt file that references the boarder of the display (see below).

# uncomment the following to adjust overscan. Use positive numbers if console
# goes off screen, and negative if there is too much border
#overscan_left = 16
#overscan_right=16
#overscan_top=16
#overscan_bottom =16

I tried various values but in the end I changed to (only changed one line below):

# uncomment the following to adjust overscan. Use positive numbers if console
# goes off screen, and negative if there is too much border
overscan_left = 32
#overscan_right=16
#overscan_top=16
#overscan_bottom =16

It definitely fixed the flyout menu.

Hope this works for you.

Thanks for contributing that. I tried setting my third party 7" display with no luck. I then just commented out those settings and voila, it worked!

Hi Guy’s I have the same problem on my side old TV 32 inch ,on the left side of it I am loosing half of the menu. and I dont’ know how to navigate to go in the config.txt to be able to modify it.
Can some one make a short how to video,

I don’t have a video. You use an SSH client on your computer like Putty if you are on Windows. If you have a Mac, SSH is already available in your terminal. You SSH to the IP address displayed on your Onefinity screen. The username by default is shown on your Onefinity Network settings, my default username is bbmc , and the default password is onefinity. Once connected, change do a ‘cd /’ to go the root directory and the ‘cd boot’. Then use nano or vi to edit config.txt which is in that directory. For me, I commented out the following as shown:

#framebuffer_width=1280
#framebuffer_height=600

(the # in front disables it)

Once I did this, I got full screen but had to change the browser to display at 50%, but with a larger monitor, you should be fine. I’m using a 7" Raspberry PI display because I’m space constrained in my shop.

2 Likes

Thank you very much, I will read your post a couple of time , and i will try it :+1:

In terminal or similar command line app:

  1. SSH to your cnc using user and password.
    a. ssh bbmc@192.168.1.30 [where bbmc is the default username unless you have changed it and IP address is your actual machine address.]
    b. [Enter password, default is onefinity unless you have changed it.]

This works and tested in Mac terminal, should be similar on PC.

1920x1080 works great to get everything on the 10" screen so you don’t have to scroll up and down but might not be suitable for sausages. If you comment out[#] the framebuffer_width and framebuffer_height then you will need to make sure the screen is turned on first before powering on the Onefinity otherwise you are likely to get 640x480 which is basically unusable. So powering everything at the power strip is impractical. Commenting out the resolution will likely result, on the 10", in booting at native 1366x768 which is usable and sausage friendly but will likely require some scrolling. You may find 1600x900 a reasonable compromise.