Screen Wont Turn On

Seeing it is the day after Thanksgiving, I had some free time to tram and set up a waste board for my Onefinity. After running to Home Depot to get some .75 MDF, I turned on my controller to find that my screen isn’t turning on. I had it on yesterday to show some family the ability of using a gaming controller to jog the head around. I have tried unplugging all the cables, and reinserting them, as well as new outlets and a new surge protector. Is there a reset button somewhere under the casing of the screen? Has anyone else had this issue?

If you have it plugged in with the 12v wall adapter and you hold the power button down and the blue splash screen doesnt come on, the screen needs replaced.

Is this something that is covered under warranty? Should I email you directly?

I had the exact same issue. The screen worked one day but it wouldn’t power on the next day. The monitor was covered under warranty. I contacted the support and they shipped a new monitor immediately.

1 Like

Same thing just happened to me. 3 carves in

My screen Is toast Too.


This just happened to me on Saturday too. I’m about to contact support to see what they say.

If your screen stops powering up, and no longer displays the blue splash screen, we will, of course, replace it under warranty.

1 Like

My screen has also stopped working. :frowning:

I can still use the machine from the Web Interface, but no touchscreen or monitor at the machine. In a few moments I will send a message to the support team.


1 Like

Email the support team. I got a reply in 2 minutes. Troubleshooting determined it was a bad screen and they are sending one out right away.


1F replaced the screen in a matter of days. Did I say how much I appreciate 1F and their team? :slight_smile:

1 Like

My screen also stoped working this week and the Onefinity support team addressed the issue on the evening of a holiday. They are replacing the screen. Fantastic customer service.

1 Like

Today my screen suddenly won’t let me touch the box that comes up asking whether to home or cancel. When I touch it nothing happens. I have rebooted the controller several times but each time the box comes up and is inactive to my touch. Any ideas?

try flipping the usb c cable in the screen 180 degrees. There seems to be a data side and non data side to the cables.

1 Like

Hi mine is doing the same thing. What worked for you?

I have to reflash the micro SD card. A bit of a process which I started but had to delay when my card reader decided to not work. Waiting on Amazon to ship a new one out tomorrow. Have yet to see if this will fix my problem.

1 Like

Working with support they had me try using a wireless mouse to see if that would get the button to click, but it did not,however I found that the new mouse was so much easier to navigate that little screen in stead of using my fat fingers to click on everything. Thank you support.

1 Like

Reflashing the micro sd card is what fixed the problem. The file was corrupt and the most likely cause was shutting down the controller using the on-off switch rather than using the shutdown menu.

1 Like

Is there an image for the RPI SD card available publicly, or did @OnefinityCNC have to send you that image to copy to the SD card yourself?

Support sent me a .7z file that I unzipped with a 7zip program that I had to download and flashed it myself.

1 Like