Touchscreen Cursor Jumping

Hello, I’ve searched the forum and haven’t found anything specifically relating to my issue, but please let me know if this is redundant.

I upgraded my touchscreen monitor to one that I saw on another post (the G Story 15.6" model here: G Story 15.6", and I’m having issues with the cursor jumping to the top left of the screen after a few minutes of being idle. The problem is that it frequently jumps up there and clicks the Refresh button on the page, constantly asking if I want to home the machine. I’m not sure if this is merely a nuisance, or if refreshing will interrupt toolpath operations, and I’d rather not find out in the middle of a job.

I’ve swapped USB cables with no luck. I’ve tried it with a mouse (having unplugged the USB-C from the monitor), and it doesn’t jump when it’s just the mouse, so it must have something to do with the USB-C connection or the monitor itself.

I’ve already modified my monitor to fit a monitor mount, so returning it would be challenging (though probably not entirely impossible), so I wanted to see if there might be another solution anyone is aware of. When I Google that type of problem, most solutions direct users to adjust mouse settings in Windows, but obviously, the controller runs on Raspberry Pi, and I don’t know of any way to access any setting in the OS.

Do I just need to get a new monitor? Thanks for any suggestions!

You mentioned changing the USB cable. Did you mean the HDMI cable?

I would try swapping it out if you haven’t tried that already.

1 Like

As far as I understand, the HDMI cable only transmits the image, right? The USB is the one transmitting the touchscreen input. And with the USB unplugged, the issue goes away, so that’s why I think it must be that. Is there a chance that the HDMI and the USB would have some sort of conflict that would cause that?