Touchscreen frozen

Just put together my newly arrived machine…followed the on-line manual religeously, as well as referrencing the setup video - both on the Onefinity website. When I came to power on the system all seemed fine, but the touch screen was frozen with a box (homing yes or cancel) displayed, waiting for input. I checked all the wiring and tried all the usb ports as well as a new usb A to usb C cable…so the touch screen is connected to 12 vdc, usb and hdmi…I’ve contacted support but so far their suggestion (turning on the touchscreen first and making sure the 12 vdc was connected) hasn’t resulted in any improvement. Any ideas? Would a regular usb mouse work?

Look for the mouse pointer on the screen to make sure it’s over the button. I’ve noticed that sometimes it does not align exactly and I have to “touch” a half-inch or so below my desired “click-point”. Usually happens when I adjust the angle of the screen… I also plan to add a mouse in the near future.

The mouse pointer is over the corner of the overall pop-up box, but doesn’t respond to touch to move or click…it’s dead.

1 Like

I have the same situation. The cursor is about 1/2" above the Yes box to start the homing process. I keep reaching for a mouse.
There are 3 cables that come with this larger (10") display. One is HDMI on both ends.
There are also 2 USB 2 to USB 3 cables and an AC power adaptor. So I have the HDMI from the control box to the display. A USB from the controller to the display and a USB from the display to an AC outlet. Seems pretty basic. Not too many variables here. Would love a suggestion

You can plug in a standard USB mouse to get going and troubleshoot the touchscreen in parallel…I know I was very excited to start making chips.



I connected the control box to the touchpad display as per online manual: hdmi to hdmi mini, usb A to usb C, and wall plugged the voltage converter connecting it to the 12vdc in……display worked, but touch not working and cursor frozen on the homing pop-up box. Checked it many times, even with other cables that I knew were fine. Nada. Ended up plugging in a usb mouse and voila! - I could move the cursor and click on buttons. I emailed back and forth with the support guy and we agreed that I would send the touch display back for replacement or credit (haven’t decided yet….might want to go with a larger display….)

Did you try swapping the USB plug-ins attached to monitor? When I first connected mine, my touch didn’t work but I literally just switched the USB cords on the side of the monitor and then the touch worked fine. I have also had the issue with the touch screen not working properly and I just restarted it and it corrected the issue. Assuming you tried swapping the cords but just thought I would share.

Yes, I swapped out the usb (usb A to usb C) cables with one that I knew was good. Still didn’t work. And I restarted the touchpad many times. I did connect a regular mouse and a regular (non-touch) monitor and it worked fine…mouse moved the cursor and clicks worked…I talked to support and they will replace or credit me for the touch pad.

Just received OF on Monday, was jogging router with touch screen and joy stick with no problems, homing went fine, then while trying to zero xyz over work piece the screen went black with white info like the gcode file but froze there and I can’t clear it away and start over. Checked all wires and connections seem fine. The usb stick that runs the joy stick was working fine but now the red lite flashes when turned on then goes out seconds later, no joy stick controls. Tried turning controler on and off many times no effect. Hopefully the screen can be cleared and on I go.
Thanks for any help! Drew Rutter

Has anyone helped you resolve this issue? If so, what was the problem. I’m having the exact same problem. It is random. Sometimes it works fine, other times it just freezes. I just home all my Axis, and when trying to set my offsets, the screen was frozen.

Actually, I connected a mouse and can home and execute programs. The problem with mine appears to be the actual touchpad failing to work with the touchscreen. I emailed support just a few moments ago.

You’ve most likely not connected the screen properly.
Check this faq here:

It works sometimes. The touchscreen feature to the touchpad fails to function intermittently.

I ended up exchanging the 7" touchscreen for the 10" one and it works fine…so the problem was with the flakey 7" monitor. Now I am considering getting a larger monitor (got used to using a 17" monitor with a separate mouse)…

Who knows maybe next year they’ll start offering a bigger monitor, wouldn’t that be nice…