Trouble with file

I’ve tried to create my first carve…with no luck so I deleted all the GCode from my post processor and deleted the file from my flash drive too. Created a new project. Home my machine and zeroed my workpiece. Put my flash drive in uploaded my file.
Started the carve and it went right back to the old file that I was having trouble with. I deleted tell of the files. Why did it go back to a file that I deleted although it said it was running the new file

Rick - did you delete the file from the controller? I’d rename the new file and make sure you have it selected before you start the cut.


I tried loading the file before I started the homing / zeroing procedure
I was able to load a new file…and start the cut but I got the same results. Agter I zero the workpiece and the cut starts to run its starts on the lower leftof the workpiece and it cuts the center top portion of the file.
I’ve tried to delete the files in the PP but there is at least 15 files showing where I attempted to run my first file. I try and delete them but they just won’t disappear…