V carve not deep enough

I’m using v carve pro and set up to v carve some letters. The preview rendering looked good but the actual carve was not deep enough. I was left with missing elements in the letters. What is the cause and fixes? Will offsets work? My Z axis was zeroed prior to starting. I still need to go deeper to fix this so any help is appreciated.
I didn’t see similar topics but probably missed it in my search.

Thx much

Defiantly not got the flat depth setting to shallow in vcarve on the tool path?

I’d verify your workpiece is flat first.

Zero your Z on the workpiece in the same location as before (I’m assuming you zero’d to the top of the workpiece) and then manually jog to the spots where the carve was not deep enough and verify that Z-zero is still touching the wood.

Thanks to all for the input. I’ll look at the flatness when I get home.