X50 locked up with downloading file message

My brand new X50 is locked up. I carved one project. Went to work with the probe a day later. I plugged the memory stick back in and was messing around familiarizing myself with down loading file. I had a simple one that I made on Carveco. It took forever and stopped at 99.99%. I hard restarted machine. Did not know what else to do. I took memory stick out. When I turned it on again it came up with message saying” processing new file please wait” it does not do anything. I restarted again and same message. I left it running went inside and googles a few ideas and posted on the Facebook page. Went back out and hour or so later. It then asked if I wanted to home the machine. I figured all was good. I jogged it around some with the wireless controller. And shut off. Turned back on today same message popped up. I did read about removing wireless controller. Tried that still locked up. Any ideas. This machine has less that an hours worth of work on it.

I’m not sure that this is your problem but it sounds a little like what I ran into this weekend. I was running a file that I had run a couple of times before but this time I had changed the file name and added a instead of () around part of the name. I wasn’t aware that there were special characters the buildbotics controller doesn’t like. I had to do a few google searches to find the answer.
In any case, it locked up in the processing phase. I hit e-stop, restarted, but got the same message when I tried to load that file. While I didn’t have the memory stick in any more, the controller still had it in it’s memory. So I had to select a file in the memory that I knew was OK. Once that loaded I selected “delete all” so the poorly named file got deleted. That fixed the problem for me.

Below is a post with a different approach.