Z axis will not zero

Newbie here. Just set up the Oneinfinity and for the life of me I cannot get the z axis to zero. It will home, but it will not zero. I’ve tried moving the z mount up and down. I’ve tried pushing the bit in further and pulling it out, as suggested on FB. Nothing is working. It still says it’s over, and I’m getting a message that “the z axis position is 31.21 mm is greater than maximum soft limit”. Can anyone please tell me what is going on. Thank you!

Hi Alan - first, welcome to the forums. It sucks you are having issues. First, did you press the “zero” button on the UI to zero the z height? Or are you using the touch plate?

If that is good, then check your limits (motor 3 is Z) and ensure they are set properly. Unless you changed them, I don’t know why they would not be set to acceptable limit.

If all that checks out, please post your gcode so we can take a look. Hope this helps.



Hi Tom,

Thank you for taking the time to help me.

What I’ve been doing is. I will start the machine up, and then home it. Everything will home fine. I then move and center the router over the project, and hit the zero button for both the x, and y axis. I will then place the probe I purchased from One Infinity and attempting to zero the z axis. This is when everything goes wrong. Sometimes it will go through the process of trying to zero, and sometimes it goes straight to giving me the error message.

I looked at the Limits for the min-soft limit and it is exactly the same as in your picture. If you would guide me on how to get the Code, I’ll post that so that you can review it. Here are pictures of what I receive after attempting to zero the z axis.

Again Thank you!


1 Like

Hi Alan - just to confirm, you place the probe on the work piece, center the bit over the probe, and then hit ‘probe for z’, right?

From what I can tell from the pictures, the machine thinks your zero is outside the limits of the z-axis for some reason. This might be because your bit is very short, or the z-axis is set very high on the x-gantry and the bit doesn’t reach the probe before hitting the soft limits (12.249 mm).

For the code (i.e., gcode), I mean the file you loaded into the OF that you want to cut – unless you are simply running the sample file that was provided on the machine.

Try homing the Z-axis, moving the axis down 10mm or so, then hitting zero. If it lets you zero there, then there is likely something wrong with the probing sequence.


Sometimes, if you try to probe for Z from too far of a distance from the metal plate, it will give you that error. Try lowering your bit (z axis) manually closer to the probing plate (3-5mm above the plate), than probe for Z. Hope that helps.

Hi Tom,

I place the probe in the lower left hand corner of the .75" piece of wood. I choose this option during project setup.

I have positioned and repositioned the z mount on all three levels, and repeated the zero process multiple times. I’ve also changed the depth of the bit multiple times and repeated the zero process with the same outcome.

I’ve tried moving the axis down 10 mm then hitting zero and it goes straight to a failed message. It won’t even probe now. Also, when I home the x axis it sit there and grinds until to give it a slight push to the right, and then it homes.

I lower the bit down to the point where it’s almost touching, and then try and probe, and I still get an error message.

This forum isn’t allowing me to upload the G-Code. I’ll keep trying.

1 Like

As a new users I"m not allowed to upload. So, I can’t upload the G-Code. Sorry

Thank you!

1 Like

Hi Alan - first, the grinding problem on the X probably means you need to adjust your stall current. Check this out:


That does not address the Z issue - I’m stumped. Recommend contacting OF support - it might be a controller issue.

Sorry I couldn’t be more help.



I appreciate your help very much, and once I figure out the issue, I will let you know what it was. Again, thank you, and I’m looking forward to future discussions. Hopefully they are positive…LOL


Did u ever resolve this. I am having same issue. I cannot get z to home. I do not have probe. Just lowering bit a piece of paper thickness off of surface.

1 Like

Idk if you are still having an issue with this but I have just had the same issue and the solution was to set my z zero to the material top not the bottom. Once I changed this setting (in CAD), the machine stopped cutting 20mm above the workpiece.

It has been a while @Haymaker and @Coop I know the post is old but what was the outcome of setting the Z axis. I’m in the same boat as you guys were. Let me know when you have a chance. I’d love to start carving.