2.0.0 Alpha 1 BB Firmware (outdated, 2/18/23)

This is the second build of 2.0 Onefinity Firmware.

This has a major rebuild that is 64 bit which will work with either RPI3 (in all current controllers) or RPI4.
Our internal testing uses this pi4: https://amzn.to/3nqKT7i

Known Issues:
1366x768 resolution does not work on RPI4 Only


New features

  • Built of 1.2.1 Features (so missing all 1.1.1 features for stability)
  • Initial Wizard
  • After Reset is clicked, initial wizard will reinitiate.
  • Network moved to master list in flyout menu instead of under ‘general’ section.
  • Incorporates 64bit programing.

If you experience issues or bugs, you must comment on this thread for us to see them. This thread is the ONLY place the developers will look to fix bugs, if you don’t post them here, they will not be fixed. By downloading the link below, you agree to post about bugs on this thread, and only on this thread (and not on the facebook group, the developers will not see it there and any facebook posts related to 2.0 alpha builds will be deleted immediately).

Download Link:

1 Like

Reserved for Onefinity #1

Reserved for Onefinity #2

Ok. So, some progress, some not so much. I am running this on a RaspberryPi 4.
FWIW, the Wizard to set up the controller is nice, simple, and fairly quick. The problem still exists from the first ALPHA build where, after reboot, it is doing a GCODE check, and just hangs. That modal is not closeable, and restarting the browser (kiosk mode, just killing it) yields the same situation. Please let me know what else I can check/change to possibly get passed this blocker.

1 Like

Please post a video of what’s going on so we can take a look.

Here you go…

Not sure but I don’t think that video posted.

I can see it when I reload the page…

1 Like

Ok but I checked again and refreshed also I see the screen and arrow to play but nothing happens. I’m just advising sorry if I’m butting in.

Confirmed. Doesn’t play for us either…

Not at all. It takes about 4-5 seconds to start playing. I did reload the page again, and pushed play… it did start. The video is about 26MB, so, depending on your Internet connection, it may need to buffer a bit.
In any case, it shows that the code starts up, shows 51% loaded, goes blank, shows 100% loaded, goes blank, then opens up the chromium browser, and presents this:

1 Like

I was able to play the video by downloading and using VLC media player.

Hi @shush : can you refresh the browser? Are you getting the same dialog box? Was the same behavior from the beginning or is it showing after your reboot? Can you please confirm the steps what you did? So that we follow the same steps again on our end and see the issue persists? Much appreciated your help here. Look forward to hear from you!!

The Chromium browser accepts no input. If I close chromium, it comes back up and does the same thing. If I reboot, it launches Chromium, and again, presents the same screen.
Steps taken:
I wrote the image onto a microSD card using Balena Etcher
Inserted microSD card into RaspberryPi 4
Booted. It took a bit, while I believe it was probably expanding the file system, then it rebooted itself.
After booting, I was presented with a wizard interface, I answered the questions, and it needed to restart once again.
This restart it went through the progression shown in the video. All of the startup sequencing, then booting into kiosk mode, launching Chromium, and automatically loading the test GCODE, and it attempts to simulate. There is sits.

1 Like

Hi @shush thanks for the prompt response. Few additional questions on our end.

  1. Were you facing the same issue with PI3 or is it happening only with the pi4?

  2. If it is happening only on your end, probably we might need to connect to your machine to understand your configuration to troubleshoot it. If it is happening with others too, then we will take someone help who can replicate the issue.

As we said, we are here to fix if there are any issues with the beta product and make it, stable one. Thanks again for your contribution.


I did not try with a PI3. I did try the ALPHA release, on a PI4, and had the same result.
Connecting into my machine would be a rather difficult challenge, but one I could make happen if necessary.

Let me ask this question, is there a way I can clear out what is in the GCODE buffer / file listing, so there is no GCODE to evaluate?

1 Like

Sure that can be doable, let me check my dev team to send the instructions to do so. Meanwhile, let me investigate this issue with logs.

Next steps:

  1. We will send the steps to SSH into machine to take the logs if necessary
  2. send you the steps to remove the Gcode or will send the another patch if we identify the issue that will fix this issue.


1 Like

I am very well versed in how to use ssh… where the logs are, sure. But I do need the credentials in order to log in.
I have tried bbmc with both buildbotics and onefinity, neither allow me to ssh in.

How do I uninstall 1.2.1. I updated without realizing it was beta :confused:. I’d like to go back in time to the last stable version

Where do we download 1.0.9?